FPSGUI

Feb 3, 2013 at 12:48pm

FPSGUI

Hi guys,

Wondering what could be the problem here, as if i run this simple patch of mine, i get higher FPS with my integrated gfx card (intel hd graphix 4000) than my dedicated (GeForce GTX660M):

Intel: 200FPS
GeForce: 60FPS

I guess it can’t be true, so maybe i miss something here?

– Pasted Max Patch, click to expand. –
#66331
Feb 3, 2013 at 2:03pm

Try (sync 0) on your jit.window. If set to 1 rendering locks to the screen refresh rate, which is likely to be 60fps. Apparently discrete and integrated gfx have a different default state.

#238757
Feb 3, 2013 at 2:28pm

Thanx, i was experimenting with that right now, as it turned out, it’s nothing to do with the speed of the card, the 60fps is some kind of upper limit only, if both car goes under (due some more calculations) then the GeForce performs better…

But still could’t override this limit, the sync is not changing anything while running on GTX660 if i turn it off on jit.window… but at least i see where to look for it now! :) thanx!

Kevin

#238758
Feb 3, 2013 at 2:31pm

do i make it right? just it still doesn’t go over 60fps…

– Pasted Max Patch, click to expand. –
#238759
Feb 3, 2013 at 3:29pm

That runs at 200fps on my GTX660Ti under OSX10.8.2. Try sending the message (sync 0) to jit.window. There was a bug in an earlier version that wouldn’t let you set it with @sync 0, though it looks like you’re running 6.0.8 which should have that fixed.

You can also try setting it on jit.render instead of jit.window, though that’s supposed to be deprecated.

#238760
Feb 4, 2013 at 7:32pm

thanx again! Neither sending the message to the window or render worked…

I checked the NVidia control panel and VSync is set to “application decide”… So i guess Max should be able to set it, althought when i’ve turned off VSync in the NVidia control panel and restarted Max, it worked :) But i had to restart Max…

Anyway it’s solved thanx, even if i don’t know why the attribute and/or message is not working inside Max!

Thanx again for your help!

Kevin

#238761

You must be logged in to reply to this topic.