fsmenubar=0 causes fullscreen video performance problem (OSX)

Dec 14, 2009 at 10:54am

fsmenubar=0 causes fullscreen video performance problem (OSX)

When I set fsmenubar=0 in a fullscreen jit.window (or ;max hidemenubar). The video jumps a lot.

here my video and window settings:

jit.qt.movie @preroll 1 @adapt 1 @highquality 1
jit.window “Video Rack” @interp 1

Any suggestions?
Thanks a lot

#47196
Dec 15, 2009 at 12:06am

i believe this is being investigated. thanks for the report. in the future please provide relevant system, software and OS specs when but reporting.
thanks.

#169682
Dec 21, 2009 at 6:46pm

Sorry about the details. Some tests later I have more data.

Two settings cause jumps in video playback

1. If I set fsmenubar=0 and fullscreen in the laptop screen
2. If I set fullscreen (no matter the value of fsmenubar) in a second screen

Otherwise, I mean fullscreen in laptop screen with fsmenubar = 1, the video runs smoothly

Macbook Pro 15′ Unibody 2.8GHz Intel Core 2 Duo 4GB DDR3
OSX 10.6.2
Ableton 8.1 with max for live
MaxMSP 5.1.0

#169683
Dec 30, 2009 at 4:49pm

Hi

If you update to 5.1.1 the problem has been fixed! You can also change the readback mode for opengl with the following:

– Pasted Max Patch, click to expand. –

Using ‘fbo’ fixes the problem pre 5.1.1 but it doesn’t perform very well on intel graphics chips (default setting is ‘rtt’)

DiGiTaLFX

#169684

You must be logged in to reply to this topic.