FTM + standalone problem!

Feb 17, 2011 at 5:13pm

FTM + standalone problem!

Hey everyone I am having another problem building a standalone application in
Max with FTM objects again.

Here’s my process again. I have tried so many times, I have no idea what is
wrong.

All my FTM objects are in a sub patch…

I open my patch (just the top level presentation patch).

I drop the externals folder onto the FTMStandaloneAnte droplet

I build my standalone in Max adding a couple of folders

I build the application into the FTMStandalone folder and then drop it on the
FTMStandalone post droplet.

When I open the new app I get this:

ftm.object: unable to load object bundle executable
2011-02-16 16:34:26.353 LHSC[1096:207] Error loading
/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/appRuntime-m
xt/ftm.object.mxo/Contents/MacOS/ftm.object:
dlopen(/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/app
Runtime-mxt/ftm.object.mxo/Contents/MacOS/ftm.object, 262): Library not
loaded: @loader_path/../Frameworks/FTMlib.framework/Versions/2.5/FTMlib
Referenced from:
/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/appRuntime-m
xt/ftm.object.mxo/Contents/MacOS/ftm.object
Reason: image not found
ftm.object: ftm.object: no such object
ftm.mess: unable to load object bundle executable
2011-02-16 16:34:26.364 LHSC[1096:207] Error loading
/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/appRuntime-m
xt/ftm.mess.mxo/Contents/MacOS/ftm.mess:
dlopen(/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/appRu
nt
ime-mxt/ftm.mess.mxo/Contents/MacOS/ftm.mess, 262): Library not loaded:
@loader_path/../Frameworks/FTMlib.framework/Versions/2.5/FTMlib
Referenced from:
/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/appRuntime-m
xt/ftm.mess.mxo/Contents/MacOS/ftm.mess
Reason: image not found
ftm.mess: ftm.mess: no such object
aka.wiiremote 1.0B7-UB by Masayuki Akamatsu
ftm.list: unable to load object bundle executable
2011-02-16 16:34:28.643 LHSC[1096:207] Error loading
/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/appRuntime-m
xt/ftm.list.mxo/Contents/MacOS/ftm.list:
dlopen(/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/appRu
nt
ime-mxt/ftm.list.mxo/Contents/MacOS/ftm.list, 262): Library not loaded:
@loader_path/../Frameworks/FTMlib.framework/Versions/2.5/FTMlib
Referenced from:
/private/var/folders/cN/cNMYWM5uE7Oe7f2dbD17Jk+++TI/TemporaryItems/appRuntime-m
xt/ftm.list.mxo/Contents/MacOS/ftm.list
Reason: image not found
ftm.object: ftm.object: no such object
ftm.mess: ftm.mess: no such object
FTM & Co 2.5.0 BETA-19 (01/2011)
Copyright © 2003 – 2010 IRCAM – Centre Pompidou
FTM JavaScript support enabled
Jitter 1.7.0 installed
FTM & Co

#55020
Feb 18, 2011 at 3:28am

You might try to locate the threads regarding FTM and building stand alones in the the FTM list archives at: http://listes.ircam.fr/wws/arc/ftm or alternately post to the mailing list in the (unlikely) event that it has not been covered…

#198120

You must be logged in to reply to this topic.