Forums > MaxMSP

funny bug with peqbank~ & spectroscope~ ?

April 3, 2007 | 4:49 pm

hi

filtering a [noise~] with a [peqbank~], i am using 2 [spectroscope~]
objects to see how my noise looks before and after the filter

strangely enough all the changes applied to the signal are also
visible in the spectroscope~ attached directly to the noise~, as if
they would change the noise generator itself – I would expect the
noise to remain unchanged, whatever happens to the signal later on –
and this is the case with other filters (lores~)

funny.. Or is there a reason for this???

best

kasper

#P user gain~ 68 181 24 100 158 0 1.071519 7.94321 10.;
#P user ezdac~ 66 318 110 351 0;
#P window setfont "Sans Serif" 9.;
#P flonum 158 67 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 118 67 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 78 67 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P window linecount 1;
#P newex 89 99 61 196617 pak 0. 0. 0.;
#P user spectroscope~ 253 187 300 100 20 0 0 0 1 1 0 0 0 0 0 0;
#X frgb 224 224 224;
#X brgb 255 255 255;
#X rgb2 0 0 0;
#X rgb3 243 204 204;
#X rgb4 255 0 0;
#X rgb5 184 184 184;
#X rgb6 0 0 0;
#X rgb7 0 0 0;
#X rgb8 255 255 255;
#X rgb9 255 0 0;
#X rgb10 255 191 0;
#X rgb11 0 191 127;
#X rgb12 127 0 127;
#X rgb13 0 0 0;
#X range 0. 1.2;
#X domain 0. 22050.;
#X done;
#P user spectroscope~ 252 71 300 100 20 0 0 0 1 1 0 0 0 0 0 0;
#X frgb 224 224 224;
#X brgb 255 255 255;
#X rgb2 0 0 0;
#X rgb3 243 204 204;
#X rgb4 255 0 0;
#X rgb5 184 184 184;
#X rgb6 0 0 0;
#X rgb7 0 0 0;
#X rgb8 255 255 255;
#X rgb9 255 0 0;
#X rgb10 255 191 0;
#X rgb11 0 191 127;
#X rgb12 127 0 127;
#X rgb13 0 0 0;
#X range 0. 1.2;
#X domain 0. 22050.;
#X done;
#P newex 68 28 39 196617 noise~;
#P message 88 120 131 196617 shelf $1 $2 $3 400. 7000.;
#P newex 68 151 51 196617 peqbank~;
#P comment 2 69 100 196617 change gains ->;
#P connect 1 0 11 0;
#P connect 1 0 5 0;
#P connect 2 0 1 0;
#P connect 3 0 1 0;
#P connect 3 0 4 0;
#P connect 11 0 10 0;
#P connect 11 0 10 1;
#P connect 9 0 6 2;
#P connect 8 0 6 1;
#P connect 7 0 6 0;
#P connect 6 0 2 0;
#P window clipboard copycount 12;


April 3, 2007 | 5:02 pm

and (of course) having a send~ receive~ between noise~ and peqbank~
makes it work the way I expected it from the beginning

best

kasper

>hi
>
>filtering a [noise~] with a [peqbank~], i am using 2
>[spectroscope~] objects to see how my noise looks before and after
>the filter
>
>strangely enough all the changes applied to the signal are also
>visible in the spectroscope~ attached directly to the noise~, as if
>they would change the noise generator itself – I would expect the
>noise to remain unchanged, whatever happens to the signal later on –
>and this is the case with other filters (lores~)
>
>funny.. Or is there a reason for this???


Kasper T. Toeplitz
noise, composition, bass, computer

http://www.sleazeArt.com

http://www.myspace.com/sleazeart


April 3, 2007 | 6:27 pm

Efficiency, man. Rather than waste CPU cycle’s synthesizing something that’s just going to be filtered out, we "go back in time," as it were, and prevent the sound from ever happening. It’s the "Back to the Filter" method.

Seriously, it looks like a bug to me. We’ll get on it.

mz

Quote: Kasper T Toeplitz wrote on Tue, 03 April 2007 09:49
—————————————————-
> hi
>
> filtering a [noise~] with a [peqbank~], i am using 2 [spectroscope~]
> objects to see how my noise looks before and after the filter
>
> strangely enough all the changes applied to the signal are also
> visible in the spectroscope~ attached directly to the noise~, as if
> they would change the noise generator itself – I would expect the
> noise to remain unchanged, whatever happens to the signal later on –
> and this is the case with other filters (lores~)
>
> funny.. Or is there a reason for this???
>
>


April 3, 2007 | 6:30 pm

Efficiency, man. Rather than waste CPU cycle’s synthesizing something that’s just going to be filtered out, we "go back in time," as it were, and prevent the sound from ever happening. It’s the "Back to the Filter" method.

Seriously, it looks like a bug to me. We’ll get on it.

mz

Quote: Kasper T Toeplitz wrote on Tue, 03 April 2007 09:49
—————————————————-
> hi
>
> filtering a [noise~] with a [peqbank~], i am using 2 [spectroscope~]
> objects to see how my noise looks before and after the filter
>
> strangely enough all the changes applied to the signal are also
> visible in the spectroscope~ attached directly to the noise~, as if
> they would change the noise generator itself – I would expect the
> noise to remain unchanged, whatever happens to the signal later on –
> and this is the case with other filters (lores~)
>
> funny.. Or is there a reason for this???
>
>


April 4, 2007 | 3:04 pm

Hi,

I opened your patch and it worked fine on my computer. Maybe
double-check the patch cords or reboot?

cheers,

Carey

On 4/3/07, Kasper T Toeplitz wrote:
> hi
>
> filtering a [noise~] with a [peqbank~], i am using 2 [spectroscope~]
> objects to see how my noise looks before and after the filter
>
> strangely enough all the changes applied to the signal are also
> visible in the spectroscope~ attached directly to the noise~, as if
> they would change the noise generator itself – I would expect the
> noise to remain unchanged, whatever happens to the signal later on -
> and this is the case with other filters (lores~)
>
> funny.. Or is there a reason for this???
>
> best
>
> kasper
>
> #P user gain~ 68 181 24 100 158 0 1.071519 7.94321 10.;
> #P user ezdac~ 66 318 110 351 0;
> #P window setfont "Sans Serif" 9.;
> #P flonum 158 67 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P flonum 118 67 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P flonum 78 67 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P window linecount 1;
> #P newex 89 99 61 196617 pak 0. 0. 0.;
> #P user spectroscope~ 253 187 300 100 20 0 0 0 1 1 0 0 0 0 0 0;
> #X frgb 224 224 224;
> #X brgb 255 255 255;
> #X rgb2 0 0 0;
> #X rgb3 243 204 204;
> #X rgb4 255 0 0;
> #X rgb5 184 184 184;
> #X rgb6 0 0 0;
> #X rgb7 0 0 0;
> #X rgb8 255 255 255;
> #X rgb9 255 0 0;
> #X rgb10 255 191 0;
> #X rgb11 0 191 127;
> #X rgb12 127 0 127;
> #X rgb13 0 0 0;
> #X range 0. 1.2;
> #X domain 0. 22050.;
> #X done;
> #P user spectroscope~ 252 71 300 100 20 0 0 0 1 1 0 0 0 0 0 0;
> #X frgb 224 224 224;
> #X brgb 255 255 255;
> #X rgb2 0 0 0;
> #X rgb3 243 204 204;
> #X rgb4 255 0 0;
> #X rgb5 184 184 184;
> #X rgb6 0 0 0;
> #X rgb7 0 0 0;
> #X rgb8 255 255 255;
> #X rgb9 255 0 0;
> #X rgb10 255 191 0;
> #X rgb11 0 191 127;
> #X rgb12 127 0 127;
> #X rgb13 0 0 0;
> #X range 0. 1.2;
> #X domain 0. 22050.;
> #X done;
> #P newex 68 28 39 196617 noise~;
> #P message 88 120 131 196617 shelf $1 $2 $3 400. 7000.;
> #P newex 68 151 51 196617 peqbank~;
> #P comment 2 69 100 196617 change gains ->;
> #P connect 1 0 11 0;
> #P connect 1 0 5 0;
> #P connect 2 0 1 0;
> #P connect 3 0 1 0;
> #P connect 3 0 4 0;
> #P connect 11 0 10 0;
> #P connect 11 0 10 1;
> #P connect 9 0 6 2;
> #P connect 8 0 6 1;
> #P connect 7 0 6 0;
> #P connect 6 0 2 0;
> #P window clipboard copycount 12;
>


April 4, 2007 | 5:52 pm

> filtering a [noise~] with a [peqbank~],

> strangely enough all the changes applied to the signal are also
> visible in the spectroscope~ attached directly to the noise~, as if
> they would change the noise generator itself

We’ve posted a new version of peqbank~ at:

http://www.cnmat.berkeley.edu/MAX/downloads/

Which should fix this problem.

mz


April 4, 2007 | 6:03 pm

Kasper T Toeplitz schrieb:
> funny.. Or is there a reason for this???

I can confirm this, very strange. Maybe the peqbank~ and spectrosscope
share some global variables. This would be a bug in both of them, one
alone couldn’t create this…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


April 6, 2007 | 1:23 pm

>
>> filtering a [noise~] with a [peqbank~],
>…
>> strangely enough all the changes applied to the signal are also
>> visible in the spectroscope~ attached directly to the noise~, as if
>> they would change the noise generator itself
>
>
>We’ve posted a new version of peqbank~ at:
>
>http://www.cnmat.berkeley.edu/MAX/downloads/
>
>Which should fix this problem.

it does

thanks you

kasper

Kasper T. Toeplitz
noise, composition, bass, computer

http://www.sleazeArt.com

http://www.myspace.com/sleazeart


Viewing 8 posts - 1 through 8 (of 8 total)