Fusion: Live DJ Producer Application

Jun 7, 2006 at 12:31pm

Fusion: Live DJ Producer Application

Hi All,

As promised I have uploaded the application, Fusion which I made for my Final Audio Systems Project at university.

Some of the elements of the graphics were adapted from pre existing software. Here are some screens:

DJ Section:
http://i64.photobucket.com/albums/h196/mrwoll/FinalBackImage .jpg

Drum Machine Section:
http://i64.photobucket.com/albums/h196/mrwoll/DrumsBackGroun d.jpg

Synth Section:
http://i64.photobucket.com/albums/h196/mrwoll/Synthbackgroun d.jpg

(Delete space at end of the links i.e DrumsBackGroun d.jpg should be DrumsBackGround.jpg. No idea why the forum does that, has happened to me before)

The version uploaded is about 30mb big as it contains a PDF user manual and will only work on MACs. I havent yet built an application from my PC laptop as it is struggeling at the momment. I intend on getting a new PC in a couple weeks so if people are interested in a Win XP version I will up that too.
The program is quite buggy at the moment as I haven’t really sat down since I handed it in to iron them out.

Fusion Application: http://www.megaupload.com/?d=XZKEAVQN

Feel free to have a go with the program post some feedback. If anyone is interested in helping develop it further then just send me an email.

Enjoy.

Will

#26326
Jun 8, 2006 at 8:37am

Will Pickersgill wrote:
> Some of the elements of the graphics were adapted from pre existing
> software. Here are some screens:
>
> DJ Section:
> http://i64.photobucket.com/albums/h196/mrwoll/FinalBackImage .jpg

better this: http://tinyurl.com/mv2x7

>
> Drum Machine Section:
> http://i64.photobucket.com/albums/h196/mrwoll/DrumsBackGroun d.jpg

better this: http://tinyurl.com/remm9

>
> Synth Section:
> http://i64.photobucket.com/albums/h196/mrwoll/Synthbackgroun d.jpg

better this: http://tinyurl.com/n82wt

> (Delete space at end of the links i.e DrumsBackGroun d.jpg should be
> DrumsBackGround.jpg. No idea why the forum does that, has happened to
> me before)

Use tinyurl.com to get them smaller (did it for you… ;-)

> The version uploaded is about 30mb big as it contains a PDF user
> manual and will only work on MACs.

The Tinyurl for the applications missing, can’t make it…

put this into your browser favorites:

javascript:void(location.href=’http://tinyurl.com/create.php ?url=’+location.href)

I have it just in the toolbar, one click and its created….

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#78571
Jun 8, 2006 at 9:28am

Thanks Stefan,

Well here the tinyurl.com link for the application:

http://tinyurl.com/zz4j3

Will

#78572
Jun 8, 2006 at 12:14pm

Will, I downloaded your application, but upon startup, the Status window is littered with a bunch of the following types of errors:

error: pictctrl: _doPicture reports -47

error fpic: sytnh1.jpg error -47 opening file

error pictslider: qtimage_open reports -47

Apart from the UI problems this presents with your app, I am especially interested in the solution to this, as I just posted a couple days ago to the Pluggo list a similar problem occurring with a Pluggo that I made; although in Max the patch opens perfectly, when used as a plugin, apparently randomly, different pict’s are not loaded by the plugin and I get similar errors above. It seems like a timing problem, that the app runs out of time to load the pict’s or something.

Anyone have any ideas??

Thanks,
Dan

#78573
Jun 8, 2006 at 12:32pm

I was having that problem as well prior to handing in my project. But I thought I had cracked it. I mean it worked when I had to do a presentation at uni for it. All required folders + files were including when building the app as well.

Maybe I didnt zip all the files required for the stand-alone as they show up differently in XP compared to MAC.

Anyone know why this happens?

Will

#78574
Jun 13, 2006 at 1:20pm

Anyone (maybe from Cycling?) have any idea on this one? It’s driving
me crazy in a Pluggo I’m building. It seems completely random, that
at some times all pics load properly, but when trying again
immediately after, some pics are not loaded….

Thanks,
Dan

#78575
Jun 13, 2006 at 6:49pm

How am I supposed to find the link to fusion? Im not japanese! :)

#78576
Jun 13, 2006 at 9:19pm

I wouldn’t have thought you would need to understand japanese to get it from:

http://www.megaupload.com/?d=XZKEAVQN

or

http://tinyurl.com/zz4j3

(both link to same page)

Thanks for the interest. :)

Will

#78577
Jun 13, 2006 at 9:49pm

Quote: Dan Nigrin wrote on Tue, 13 June 2006 14:20
—————————————————-
It seems completely random, that
> at some times all pics load properly, but when trying again
> immediately after, some pics are not loaded….

Dan, you say that sometimes the pictures load properly and sometimes not on your pluggo patch. Has that happened with mine ? Has it actually ever correctly loaded on your MAC ?

Just curious.

Thanks

Will

#78578
Jun 14, 2006 at 12:37am

To be honest, I’ve not tried with your app on multiple occasions – I
think I tried twice, and on each time it didn’t load all the pics.

I’ll give it a few more tries and see what happens…

Dan

Dan Nigrin
Defective Records
202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X
http://www.defectiverecords.com

http://www.jackosx.com

#78579
Jun 14, 2006 at 5:37am

Will Pickersgill wrote:
> I wouldn’t have thought you would need to understand japanese to get it from:
>
> http://tinyurl.com/zz4j3

The problem was that the site wants to annoy you for too long (30
seconds) until you might find it. I was trapping over the same problem…

Will: I recommend to change the host, there is enough free space on the
web which is less annoying, creates less hassle and less questions to
answer..

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#78580
Jun 14, 2006 at 1:24pm

Will, I tried it about 5 more times, and each time, it failed to load at least some pictures. It missed different ones at different times. Totally random! I wish I could figure this out, as I continue to have the same problem in my Pluggo…

Thanks,
Dan

#78581
Jun 14, 2006 at 2:20pm

Thanks Dan for trying it out again. So sometimes some pictures do load though? Really weird.

Stefan – Regarding web hosting sites, the only ones I can think of (megaupload, rapidshare, megashares) all have a timer before the download is available, apart from yousendit but then its only hosted for 7 days. Can you recommend any hosts which would be more straight forward to use?

#78582
Jun 14, 2006 at 2:33pm

Yes – on some occasions, the UI was almost completely white because
so many pictures were not loaded. On other tries, most loaded,
except perhaps for 4 or 5….

Dan

Dan Nigrin
Defective Records
202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X
http://www.defectiverecords.com

http://www.jackosx.com

#78583
Jun 14, 2006 at 2:45pm

Thanks again for testing it. Wish I had known this was an issue earlier as I was panicing slightly before I had to submit it for my uni course as some images were not loading and had no idea why.

Really dont understand why it would have trouble loading them if they are already encapsulated into the application. As you have said this is one for cycling ’74 I guess.

Will

#78584
Jun 14, 2006 at 2:45pm

Will, I havent downloaded Fusion yet again,
but I offer you some space in my hosting, if you like
just email me and you can upload your stuff to my server
then Ill put a link to your files on my software page
then you can pass the link to anyone
I think we should help us together

this is mi email : mail@cooptrol.com
this is my software page:

http://www.cooptrol.com/software/cooptrol_software.htm

best
hernan

#78585
Jun 15, 2006 at 2:19pm

Many thanks to Hernan for now hosting my Fusion application on his website. The application can now be found at:

http://www.cooptrol.com/software/friends.htm

Again many thanks Hernan!

Will

#78586

You must be logged in to reply to this topic.