Forums > Gen

Gen Bug in 6.0.7

September 25, 2012 | 2:24 pm

Hi, I post this bug patch, I’ve isolated the code that give error, it seems that gen doesn’t like when I do [cell]-[/ dim].

It give me this error:

– START GLSL INFO LOG: fp –
0(87) : warning C7532: global type sampler2DRect requires "#version 140" or later
0(87) : warning C0000: … or #extension GL_ARB_texture_rectangle : enable
0(118) : warning C7531: global function texture2DRect requires "#extension GL_ARB_texture_rectangle : enable" before use
0(141) : error C1102: incompatible type for parameter #1 ("v1")
0(141) : error C1102: incompatible type for parameter #2 ("v2")
0(141) : error C1102: incompatible type for parameter #3 ("v3")
– END GLSL INFO LOG: fp –
jit.gl.shader: GLSL program failed to compile.

This is the patch:

– Pasted Max Patch, click to expand. –

And, where can I download Max 6.0.5 for windows? I need my patch working for saturday!!! And I also need to continue working on my patch!!
Please give me Max 6.0.5 for windows. :’(

My system is:
Windows 7 64bit
Intel Core 2 Duo T5800 2GHz
3Gb RAM
Nvidia GeForce 9300M GS 512Mb


September 25, 2012 | 2:42 pm

Sorry, it seems that the problem presents, when I attach the [in2]-[< 0.5] to the [?] condition inlet…

And, ok, I’ve resolved putting a [swiz] after the [in2].

this is the updated patch

– Pasted Max Patch, click to expand. –

September 25, 2012 | 5:10 pm

Hi Esnho,

I can reproduce here, and we will be taking a closer look at the issue.

Thanks,
-Ben


Viewing 3 posts - 1 through 3 (of 3 total)