gen extrusion problem

Oct 15, 2012 at 8:19am

gen extrusion problem

I’m trying to extrude a matrix from a gridshape with gen. The extrusion is working so far but the result are not as excepted.
The image should influence the z axis of the grid shape, but in my example this is not working correctly.. I cant recognize the image anymore. mapping issue?

Thanks for any help..

– Pasted Max Patch, click to expand. –
#64773
Oct 15, 2012 at 8:39am

hm, i might be completely off topic, but do you know about @matrixoutput 1 (and 2) attributes for jit.gl objects, which allow for export apparently ?

#233586
Oct 16, 2012 at 4:23pm

yes, I know that. If you look at the patch you will see that I’m using a gridshape with matrixoutput 1.
I’m trying to extrude only a small part of the gridshape. Nobody?

#233587
Oct 16, 2012 at 6:26pm

hi there!
i think that “you can’t recognize the image” cause you map it onto a sphere.
if you use a plane instead it pretty much works fine.
also
you don’t need lighting and shading options in your source gridshape because you’re using it with @matrixoutput 1
and you don’t need [swiz z] after [in2] inside gen because you only got one plane there.
look at this:

– Pasted Max Patch, click to expand. –

`

#233588
Oct 16, 2012 at 6:40pm

thanks a lot for the help, but I want to use a sphere not a plane. I want to reduce the video size and extrude
on a sphere. Is that possible?

#233589
Oct 16, 2012 at 8:57pm

When you extrude a shape, you’re pulling the vertices along their surface normal. For a plane, this is the positive Z direction. For a sphere, it’s the same direction as the vertex position (i.e. for a unit sphere, the position and the normal are exactly the same). For other shapes, like a cube, the extrusion direction would change depending on which face of the cube a particular vertex was on.

Here’s a patch that extrudes a sphere and texture maps it with the video image.

– Pasted Max Patch, click to expand. –
#233590
Oct 16, 2012 at 9:14pm

wesley, you are gorgeous! thanks so much for that!!

#233591

You must be logged in to reply to this topic.