Getting matrix-type pixelation effects from downsampling via jit.gl.slab

Dec 5, 2009 at 6:49pm

Getting matrix-type pixelation effects from downsampling via jit.gl.slab

I had a patch where I was rendering from some jit.gl.sketch objects to matrices and then running them through some feedback matrices ripped straight out of Tutorial 18. I got some really nice interaction when I set the downsampling (by this I mean low-pixel count dimensions of specific matrices) high and mixed the output of several of these chains together.

I’ve now rebuilt my patch so that all processing is done on jit.gl.slab objects, but I can’t seem to achieve the same effect. When I tell a slab to downsample (which I’m doing the same way, sending it a dim $1 $2 message), it works, but the effect is completely different. Instead of getting nice crisp squares each of a single color, I get blurry gradient blobs. I can see that technically it is downsampling like I want it to (at higher pixel values the two techniques look more similar, and at lower values the blobs are clearly getting fewer and larger), but I want nice crisp squares again (or, ideally, the means to switch between the two effects on the fly).

I’ve tried sending @blending_enable 0 messages to everything under the sun because it seems like something like that is happening – at some point the output of this nice pixelated slab is being interpolated once upsampled to full resolution again, but I can’t find the point where that’s happening or turn it off.

Any help please? Is there an attribute for this, or has someone written a shader that would simulate this effect?

#47038
Dec 5, 2009 at 9:31pm

on your capture texture (the one capturing the gl.sketch) set the “filter” attribute to “none”.

#169107
Dec 8, 2009 at 2:30am

This produces no visible changes.

#169108
Dec 8, 2009 at 3:00am

Hmmm…I’ve simulated it by setting poly_mode 2 2, dim x x, and point_size y, but this only works on the videoplane. I need to make it happen on the slab level. I can’t have more than one videoplane feeding a single context, can i?

#169109
Dec 8, 2009 at 3:32am

Success! Sent the downsampling slab “sendoutput filter none”. Thanks again, robtherich. That’s twice you’ve solved my problems. I really appreciate it.

#169110

You must be logged in to reply to this topic.