Forums > MaxMSP

Getting umenu to read multiple MIDI files

February 22, 2013 | 2:00 am

I’m having a hell of a time simply getting Max to find my MIDI files and play them back. I just want to populate the umenu with a couple variations of a bassline and I want it to load when I open the patch and recognize where the files are saved. I’ve tried for quite some time but nothing really seems to work. If anyone has any insight on this I’d be forever grateful! Thanks so much :-)

Sincerely your fellow Max noob


February 22, 2013 | 3:30 am

Without an example patch or more detail I’m guessing (again), but here are some common issues encountered with Max with regard to reading/loading files:

The folder (or its parent folder) where the Midi files are located needs to be in at least one of Max’s search paths. (set from Options/File preferences)
Spaces in filenames/pathnames may create issues depending on how you are dealing with them: In general, when working with Max I avoid using file paths or file names that contain spaces anywhere in them. IMO It makes life with MAx easier…
Umenu or Folder may not recognize the file without its extension (in this case I guess it would be .MID)
To reliably find the umenu with your midi files on patcher load, you may need to use the ‘[folder] object.

That’s probably the most obvious stuff. HTH


February 22, 2013 | 4:26 am

Thanks for the quick reply! I actually ended up getting it to work in the end. Great tips too though. Thanks for the tips and next time I post I’ll include the problem patch (this is my first time posting in the forum). Take it easy :-)


Viewing 3 posts - 1 through 3 (of 3 total)