gl.text2d with automatic 0 ignores layer?

Jun 7, 2009 at 10:10pm

gl.text2d with automatic 0 ignores layer?

Hey folks,

I’m using text2d to place some text in various spots per frame.. the issue is that the text is always drawing first and all other objects/sketches/slabs are covering it up. It’s almost as though automatic 0 makes the layer 0 as well. Any thoughts on this?

Peace,
Drew

#44286
Jun 10, 2009 at 7:01pm

best way we can help is to see a stripped down patch illustrating the problem.

#159235
Jun 10, 2009 at 8:20pm

Nevermind… I resolved it… human error. Smile I’ll be sure to always post patches from now on.

EDIT: Actually not; I tested it with gl.sketch and it works fine, but gl.gridshape (the original perp) doesn’t work…

#159236
Jun 11, 2009 at 1:44am

Actually, I was mistaken. The bug continues and I am unable to resolve it. I’m about to pull my hair out on this one.

Here’s a simple patch that demonstrates the strange bug. I assume that setting the text to layer 99 and the gridshape to layer 0 will make the text draw in front of the gridshape, however, it draws behind it.

– Pasted Max Patch, click to expand. –

Any help would be greatly, greatly appreciated!

Thanks!

Peace,
Drew

#159237
Jun 11, 2009 at 9:37am

AFAIK the layer attribute is only relevant when automatic is 1 . When automatic is 0 you have to explicitly draw each object in order. I think automatic 0 is only useful when you set all of your gl objects to automatic 0.

i think this is what you want:

– Pasted Max Patch, click to expand. –
#159238
Jun 11, 2009 at 11:27am

Bingo!

Thanks a billion!

#159239

You must be logged in to reply to this topic.