Forums > Jitter

gl videoplane texture problem

February 18, 2008 | 9:07 pm

Hi

I have a small texture issue in a patch I’ve made to play video’s on a gl videoplane. When I go fullscreen or move the jit.window to another monitor it rebuilds and I get:

jit.gl.render: building GL on window "visualiser"…
• error: jit.gl.texture: unable to create texture!

Unsure why I get this error, how to fix it or why I even need a texture as my patch seems to work without a texture. Any help much appreciated.

a+
gar

max v2;
#N vpatcher 381 103 1205 629;
#P origin -354 -74;
#P window setfont "Gill Sans" 10.;
#P comment 324 276 32 278003722 Loop;
#B frgb 100 100 100;
#P window setfont "Sans Serif" 9.;
#P user ubumenu 355 275 45 196617 0 1 1 0;
#X add Off;
#X add On;
#X prefix_set 1 1 text 0;
#P user pictctrl 383 239 17 32 green-indicator-2.jpg 0 0 1 0 0 0 0 0 33 28 128 0 1 1 2 0 1 270;
#P noclick;
#P window setfont "Fixedwidth Serif" 10.;
#P message 378 147 14 1441802 0;
#P window setfont "Sans Serif" 9.;
#N vpatcher -8 279 784 730;
#P origin -50 23;
#P window setfont "Sans Serif" 9.;
#P window linecount 0;
#P newex 592 145 30 196617 t b b;
#P message 267 298 87 196617 texture texture2;
#P window setfont "Gill Sans" 10.;
#P window linecount 1;
#P comment 258 54 39 278003722 Restart;
#P inlet 296 53 15 0;
#P comment 177 54 47 278003722 Jitter QT;
#P inlet 223 53 15 0;
#P window setfont "Sans Serif" 9.;
#P newex 296 185 43 196617 jit.qball;
#P newex 296 208 58 196617 t b b erase;
#P message 356 209 70 196617 camera 0 0 4;
#P newex 452 311 113 196617 jit.gl.render visualiser;
#P newex 249 334 130 196617 jit.gl.videoplane visualiser;
#B color 5;
#P newex 597 115 48 196617 loadbang;
#P window setfont "Fixedwidth Serif" 10.;
#P message 296 141 14 1441802 1;
#P newex 296 163 52 1441802 metro 2;
#P connect 12 0 3 0;
#P fasten 8 0 3 0 228 278 254 278;
#P connect 6 0 12 0;
#P connect 10 0 1 0;
#P connect 1 0 0 0;
#P connect 13 0 0 0;
#P connect 0 0 7 0;
#P connect 7 0 6 0;
#P connect 13 1 5 0;
#P fasten 5 0 4 0 361 233 457 233;
#P connect 6 2 4 0;
#P connect 6 1 4 0;
#P connect 2 0 13 0;
#P pop;
#P newobj 431 348 170 196617 p jitglcontrol;
#N vpatcher 227 443 866 905;
#P origin 26 0;
#P window setfont "Sans Serif" 9.;
#P window linecount 0;
#P newex 322 343 194 196617 jit.gl.texture visualiser @name texture2;
#B color 5;
#P message 258 158 41 196617 loop $1;
#P inlet 258 53 15 0;
#P window setfont "Gill Sans" 10.;
#P comment 231 54 32 278003722 Loop;
#P window linecount 2;
#P comment 255 389 48 278003722 Jitter QT out;
#P outlet 304 393 15 0;
#P user panel 23 370 574 56;
#X brgb 255 255 255;
#X frgb 255 0 0;
#X border 2;
#X rounded 0;
#X shadow 0;
#X done;
#P comment 140 49 53 278003722 Play/pause quicktime;
#P inlet 194 53 15 0;
#P comment 299 49 48 278003722 Restart quicktime;
#P inlet 348 53 15 0;
#P comment 42 49 53 278003722 Open quicktime;
#P inlet 96 53 15 0;
#P user panel 23 30 574 61;
#X brgb 255 255 255;
#X frgb 255 0 0;
#X border 2;
#X rounded 0;
#X shadow 0;
#X done;
#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P newex 393 229 43 196617 jit.qball;
#P newex 128 179 44 196617 togedge;
#P message 162 205 29 196617 stop;
#P message 128 205 33 196617 start;
#P message 96 205 30 196617 read;
#P newex 286 185 48 196617 loadbang;
#P message 286 230 61 196617 autostart 0;
#P window setfont "Fixedwidth Serif" 10.;
#P message 348 229 43 1441802 time 0;
#P message 393 161 14 1441802 1;
#P newex 393 207 52 1441802 metro 2;
#P newex 304 285 128 1441802 jit.qt.movie 320 240;
#B color 5;
#P connect 12 0 6 0;
#P fasten 16 0 9 0 199 175 133 175;
#P fasten 2 0 7 0 398 181 173 181 173 201 133 201;
#P connect 9 0 7 0;
#P connect 9 1 8 0;
#P connect 22 0 23 0;
#P fasten 5 0 4 0 291 216 291 216;
#P fasten 4 0 0 0 291 250 309 250;
#P fasten 6 0 0 0 101 267 309 267;
#P hidden fasten 3 0 0 0 353 250 309 250;
#P fasten 7 0 0 0 133 265 309 265;
#P fasten 8 0 0 0 167 263 309 263;
#P fasten 10 0 0 0 398 252 309 252;
#P fasten 23 0 0 0 263 259 309 259;
#P connect 0 0 19 0;
#P fasten 0 0 24 0 309 325 327 325;
#P connect 14 0 3 0;
#P fasten 14 0 2 0 353 157 398 157;
#P connect 2 0 1 0;
#P fasten 5 0 1 0 291 204 398 204;
#P connect 1 0 10 0;
#P pop;
#P newobj 253 360 93 196617 p quicktimecontrol;
#P newex 329 147 48 196617 loadbang;
#P window setfont "Gill Sans" 10.;
#P comment 410 64 93 278003722 Visualiser window;
#P window setfont "Sans Serif" 9.;
#P newex 231 78 339 196617 jit.window visualiser @rect 10 50 330 290 @idlemouse 1 @fsmenubar 0;
#P window setfont "Fixedwidth Serif" 10.;
#P message 323 188 14 1441802 1;
#P user jsui 324 239 60 32 1 0 0 jsui_texttoggle.js Play Pause 100 100 100 240 240 240 "Gill sans" 0.5 0.25 2;
#P user jsui 405 239 77 32 1 0 0 jsui_textbutton.js Restart 100 100 100 240 240 240 "Gill sans" 0.5 0.25 2;
#P user jsui 242 239 77 32 1 0 0 jsui_textbutton.js Open 100 100 100 240 240 240 "Gill sans" 0.5 0.25 2;
#P user panel 238 234 330 62;
#X brgb 40 40 40;
#X frgb 255 255 255;
#X border 1;
#X rounded 0;
#X shadow 0;
#X done;
#P window setfont "Gill Sans" 18.;
#P comment 241 209 124 278003730 Video Controls;
#B frgb 230 230 230;
#P user panel 238 209 330 30;
#X brgb 120 120 120;
#X frgb 255 255 255;
#X border 0;
#X rounded 0;
#X shadow 0;
#X done;
#P connect 3 0 10 0;
#P connect 5 0 10 1;
#P connect 14 0 10 2;
#P fasten 4 0 6 0 410 269 402 269 402 185 328 185;
#P connect 12 0 5 0;
#P connect 6 0 5 0;
#P connect 4 0 10 3;
#P connect 12 0 14 0;
#P connect 9 0 12 0;
#P connect 5 0 13 0;
#P connect 4 0 11 1;
#P pop;


February 18, 2008 | 9:30 pm

Moving this topic to the jitter forum


February 18, 2008 | 10:03 pm

Works fine here, so I don’t know where that problem might be, some system info might be of assistance for locating the problem, especially graphics card.

You can indeed send the quicktime movie directly into jit.gl.videoplane without the need for a jit.gl.texture.

b.


February 18, 2008 | 10:13 pm

Hi

>Works fine here, so I don’t know where that problem might be,
>some system info might be of assistance for locating the problem,
>especially graphics card.

Mac OS 10.4.11, 1.8 GHz PowerPC G5
ATI Radeon 9600 Pro

two monitors on my computer
Apple Studio Display: 1280 x 1024
VGA Display: 1024 x 768 @ 75 Hz

>You can indeed send the quicktime movie directly into >jit.gl.videoplane without the need for a jit.gl.texture.

with and without the texture I get the same error, the jit.gl.texture.help file should be identical to my patch where its important but it’s not producing any errors. this is the last fix I need to do in my (original bigger) patch, it’s not crucial but it would be nice to weed it out.

a+
gar


February 18, 2008 | 10:25 pm

I’ve opened your patch several times but I’ve been able to reproduce the error only once, but with no clear reason as to why it occurred…
Maybe the openGL experts have more on this…


Viewing 5 posts - 1 through 5 (of 5 total)