Glitch with Button + opendialog

Aug 13, 2008 at 9:26am

Glitch with Button + opendialog

Don’t know if this has possibly been fixed in 5.0.4, but if you use a Button to bang an opendialog in 5.0.3, it stays lit (as though ‘mousedown’ were true) after the dialog closes.

– Pasted Max Patch, click to expand. –
#39259
Aug 13, 2008 at 9:29am

Workaround: Throw a [del 1] between the button and the dialog, but this shouldn’t be necessary.

#137929
Aug 13, 2008 at 6:36pm

thanks for catching this and bringing it up. I’ll pass it along.

All the best,
-Ben

#137930
Aug 13, 2008 at 6:56pm

On Aug 13, 2008, at 2:26 AM, mushoo wrote:

> Don’t know if this has possibly been fixed in 5.0.4, but if you use
> a Button to bang an opendialog in 5.0.3, it stays lit (as though
> ‘mousedown’ were true) after the dialog closes.

Not that this shouldn’t be addressed, but I think Max 4 did this, too.

-C

Chris Muir
cbm@well.com

http://www.xfade.com

#137931
Aug 13, 2008 at 9:12pm

I can see instances where I might like to have something similar to this functionality – say a ‘settings load’ button that stays lit if you’ve loaded a file from disk, or something, but I think there’s better ways to do that.

I donnon if Max4 did this or not, my max4 patches never had me opening dialogs. I rarely made patches designed for other people to use, but with the max5 presentation mode I’m leaning heavily towards a userbase of more than 1. :P

#137932
Aug 13, 2008 at 9:45pm

this should be fixed for the next incremental.

-b

#137933

You must be logged in to reply to this topic.