Forums > MaxMSP

GrainTools/kfilter

February 7, 2006 | 2:04 am

Hello,
I’m trying out Grain Tools and it needs the kfilter external which I’ve downloaded and placed in my externals folder but when I open up a Grain Tools objects I get the ‘kfilter no such object’ error message. The Grain Tools objects do seem to play/perform though. Is there a way to get kfilter to be recognized? I’ve searched the archive and found no kfilter topics that address this…
Thanks,
Doug Michael


February 7, 2006 | 8:27 am

Hi Doug

the version of kfilter that David Rokeby has on his site right now
seems to be corrupt. I’ll send you a copy off-list, but David if
you’re reading this wassup?

the grain tools patches will work without the kfilter object as long
as you don’t try to use the pitched transposition mode.

cheers

Marcel


February 7, 2006 | 9:33 am

Just been through something like this – the main thing is you need to
put kfilter in the Max-startups folder, not the externals folder.
I also found that the version I downloaded needed to have its
filetype changed back to iLaF (instead of ‘iLa) and the Creator set
to max2. The open with item also needed setting to max/msp. (All this
is the Get Info/Attributes dialogue)

David


February 7, 2006 | 3:58 pm

Hello,
Thanks Marcel – that did the trick.
Doug Michael


February 9, 2006 | 7:31 pm

> Just been through something like this – the main thing is you need to
> put kfilter in the Max-startups folder, not the externals folder.
> I also found that the version I downloaded needed to have its
> filetype changed back to iLaF (instead of ‘iLa) and the Creator set
> to max2.

oh wow, yes i also remember that i could not load
kfilter one day – when i tried to postload it into
a running MAX app.


Viewing 5 posts - 1 through 5 (of 5 total)