granular synthesis musings – not really a question

Jan 19, 2013 at 8:12pm

granular synthesis musings – not really a question

Hi

as you may be aware, i’m chipping away at this old granular playback engine of mine/ours; based on the idea of one core phasor + 2 [play~] objects 50% out of phase with each other. For an as yet unknown reason when the grain size is a multiple of 40 (ms), linear playback sounds damn near perfect: an A/B comparison of the file played back via sfplay OR my granulator reveals (subjectively anyway) NO artefacts or warbling or colouration. I’m not concerned here with grain clouds etc, just linear playback for the moment. To my question: has anyone encountered (in practice or in the literature) a reference to grain sizes which are multiples of N? If I use a grain size of 82, 121 or 45 ms then the old Dalek AM/RM warbling occurs. 40, 80 or 120 (divided by 2 obv, cuz of the shifted grain) produce no discernible artefacts at all.

I’m driving my grain window(s) from 1 phasor and the window duration is tied to grain size obviously. Why should it be that any deviation from 40, 80 or 120 produces warbling? I’m not posting a patch yet for 2 reasons: 1, it’s a simple phasor –> play * window (+ phase shifted copy) and; 2, the algorithm doesn’t offer any clues.

ps
I’m familiar with the Curtis Roads text on this subject.

Brendan

#66133
Jan 20, 2013 at 12:25am

What’s your event interval/poll throttle/queue throttle/slop/etc set to? I know you’re probably entirely in the signal domain, but I’m curious if those might have an effect on it.

What happens at 20ms? or 60ms?

#238071
Jan 20, 2013 at 4:16pm

Hi MuShoo

I’ve tried various settings under Audio with no discernible change; here’s a patch describing the issue:

– Pasted Max Patch, click to expand. –

Thanks
Brendan

#238072
Jan 20, 2013 at 5:14pm

Not *entirely* in the signal domain… Line~ works better. So the issue would be down to scheduler interacting with line (& sah).

– Pasted Max Patch, click to expand. –
#238073
Jan 20, 2013 at 5:35pm

Hi spectro

Do not ask me to explain why I used line and not line~. Indefensible.

Thanks a million guys

ps
throttle and slop are mysterious terms….

#238074

You must be logged in to reply to this topic.