Forums > MaxMSP

Granulator Problem


Joe
January 8, 2013 | 7:18 pm

Hi guys,

Don’t suppose there is anyone who can look at a picture of a granulator and have a guess what is wrong with it?

I am getting an input, but no output.

I don’t even think it is recording :/

Bit confused to why it isnt working

Cheers,

J



Joe
January 8, 2013 | 9:28 pm

here is the picture, any ideas?

[attachment=211943,4857]

Attachments:
  1. granulatorproblem.jpg

January 8, 2013 | 9:39 pm

Mate, if you post a screenshot of a small section of a messy patch, you are gonna get zero help with this.

1. use the [meter~] object to hunt down signal issues;
2. use the [print] (or right inlet of the [message] object) to troubleshoot data flow;
3. post your patch



Joe
January 8, 2013 | 10:37 pm

thanks for the advice pal.

I have cleaned up the patch

– Pasted Max Patch, click to expand. –

hope this was better, really appreciate the help


January 8, 2013 | 11:16 pm

just glancing at it, you don’t have any targeting messages going to your [poly~]; no-one can see inside the [poly~] btw, as this subpatch only exists on *your* computer



Joe
January 9, 2013 | 1:08 pm

nooby question, but what is a targeting message?

Is there a way of posting a patch with the subpatches included? or do I need to post the subpatch separate

cheers for the help mate


January 9, 2013 | 2:13 pm

With a target message a list can be send to a specific instance. However, since you use the ‘note’ message, targeting is not necessary. What is important is to free voices using the thispoly~ object inside the midget-granulator.maxpat. Take a look at its help file.

Both the buffer~ and record~ objects have connections to a waveform~ but they don’t do anything. If you want to see the content of the buffer there, send it a message ‘set dathing’ instead.



Joe
January 9, 2013 | 4:07 pm

right that makes a bit more sense, however you lost me with free voices. I checked the help file for thispoly~ but could not see how I can use it to free voices. I noticed the thispoly~ in the subpatch has nothing connected to the outlets, is this the problem?

here is the subpatch

– Pasted Max Patch, click to expand. –

cheers for the help jvkr

J


January 11, 2013 | 12:03 pm

Hi

from the [thispoly~] helpfile:

"You can also connect a signal to thispoly~ to set the "busy" state; when the signal is non-zero, the busy state is set, when it is 0, it is not set."

This means the 0. or 1. signal (from [line~] will dictate when the voice is free or busy.

Brendan



Joe
January 15, 2013 | 4:54 pm

cheers pal, got it working

and sounding cool

cheers,

J


January 15, 2013 | 5:59 pm

care to upload the working patch?



Joe
January 16, 2013 | 10:26 pm

I will do of course! just trying to find out how to make a standalone! will it include subpatches and externals? or is that something that will need to be added myself? if so… how?

cheers, j



Joe
January 22, 2013 | 10:22 pm

Just a heads up, this is the gesture granulator in action, will be uploading the patch very soon :)

http://www.youtube.com/watch?v=2nU_PnUcSwc

let me know what you think, I would really appreciate your comments

J


Viewing 13 posts - 1 through 13 (of 13 total)