Forums > MaxMSP

Groove Object Clicks and Glitches when content is changed/randomized

October 4, 2010 | 10:21 pm

Hi all,
My max4live patch is now at version 1.2, please see here: http://www.maxforlive.com/library/device.php?id=406
It’s not a work of art, but does its job.

One issue remains: it glitches and clicks when I update the content of the included Groove Object via randomization. (To hear the clicks, browse and load some samples into the patch and set parameters to the same as attached picture, then click the bang object left to the start time continuously / or trigger some midi notes)

Does anybody know why that is? Should I take another object, not Groove? Is it because of some delays in the patch? Would some kind of fade in/out help and how to achieve that?
Thanks a lot for looking at it.

manu

[attachment=142952,1213]

Attachments:
  1. Screen_shot_2010-10-05_at_00.13.07.jpg

October 4, 2010 | 11:30 pm

hard to say without a patch, and to help you i shouldn’t have to sign up for maxforlive.com to download and check it out, you should just post an additional copy here(just a suggestion, though, no biggie for me).

but if you change samples in the buffer~ object, in particular, this is always an asynchronous operation so you have to use the right-outlet of buffer~ to help trigger appropriate windowing(the window would ramp to 0 when changes are desired, then change the sample, then ramp back up to amplitude of 1 after buffer~ outputs its file-loaded bang from the right outlet).

the other things like changing sample-length and playback position might also need appropriate windowing.

hope that helps.

________________________________
*Never fear, Noob4Life was never here!*


Viewing 2 posts - 1 through 2 (of 2 total)