Groove~ plays normal speed at value 2

Mar 11, 2012 at 12:18am

Groove~ plays normal speed at value 2


Just building my first patch and found something strange, all documentation Ive read says that a 1 sent to the sig~ an then to the left inlet of the groove object causes it to play the buffer at normal speed, however on my case it plays normal speed at 2 and the 1 causes half speed,

What am Im missing?

The patch:

– Pasted Max Patch, click to expand. –
Mar 11, 2012 at 2:47pm

The odd thing is that it only happens on my work computer, my laptop works as expected. Any ideas?

Mar 11, 2012 at 3:37pm

Something wrong with the sampling frequency ? Are both softs set to 44.1 khz for example ? Don’t have Live right now so I cant try it.

Mar 11, 2012 at 3:41pm

Maybe the sample rate in your audio settings?

Mar 13, 2012 at 11:32pm

This seems really odd. It happens also on my macbook when I switch sampling frequency. If the patch is running at 44.1 everything works as expected, but when I change it to 96k everything goes bizarre.
Isn’t Live supposed to take care of sampling frequency issues?
I understand Max’s audio driver is disabled when working as m4l so there shouldn’t be too many option for me to mess things up.

Any ideas?
Is this a bug?

Mar 15, 2012 at 1:46pm

Do you change the sample rate on the fly? Once you’ve recorded the samples are stored with the current sample rate, so if you change the sample rate after recording groove~ will consider the samples at the current sample rate.

Mar 16, 2012 at 3:56pm

I’ll re-check again, but I’m pretty sure I recorded the buffer at 96k. I’ll try again and report.


You must be logged in to reply to this topic.