Forums > MaxMSP

groove~ problem. How to play the whole length of sample

March 23, 2010 | 4:26 pm

Hi there.
I am trying to make sampler using groove~ object, yet the problem is the actual playback time is not the actual sample length. So not matter a whole song or just a short drum loop there is only around 1.5s playback time. I can modify it by changing the loop end time but that mean i need to know what long the sample exactly and each time i change the sample i need change to loop end time.
So I m wondering is there anyway I can just play the whole length of the buffer automatically ?
Thank you all.



MIB
March 23, 2010 | 6:25 pm

You need to tell groove~ where to start playing in the buffer. So if you have loop turned off and you send a "0" to groove~, it will start playing from the beginning of the buffer to the end of the buffer (that is assuming you are sending it a positive sig~ number).

If that doesn’t help, post the patch…


March 23, 2010 | 6:26 pm

are you accessing a ‘live’ buffer or using pre-recorded samples/loops? The [groove~] object reads from a [buffer~] of fixed size; it sounds like you need to resize this buffer using the [size $1] message or as an argument, but this also clears or initializes the buffer; the [info~] object will give lots of info, including size, of the buffer contents; try this patch:

– Pasted Max Patch, click to expand. –

Viewing 3 posts - 1 through 3 (of 3 total)