groove~ tempo change issue

Sep 8, 2011 at 2:11pm

groove~ tempo change issue

Hello,

I’m having an issue with groove~ and tempo change. When the loop start point is greater than 0. ms I get clicks when I change the tempo on the transport. This happens even though looping is turned off. Is there an explanation for this and a way around it?

Any help would be much appreciated!

Here’s an example:

– Pasted Max Patch, click to expand. –

Cheers!

#58806
Sep 8, 2011 at 3:41pm

1) try startloop

2) poly~

3) attack for amp envelope

#211388
Sep 8, 2011 at 4:10pm

Thanks for the reply.

I want to be able to start the sample from the beginning with the loop section occurring later, so startloop won’t work.

The same thing happens within poly~ and attack envelope doesn’t help.

Also, this phenomenon occurs only with tempo change in the transport. If I change the metro speed independent of the transport there is no issue.

This seems like something inherent to the relationship between groove~ and transport?

#211389
Sep 9, 2011 at 2:53pm

Hi sample rate may remove clicks.

the amp fall fast will generate clicks .so i think you need envelop for every clip

#211390
Sep 9, 2011 at 2:59pm

clicks are a central problem to msp, you won´t get around sth like a mini envelope.

#211391
Sep 9, 2011 at 3:44pm

Hi rham
I think the problem lies deeper than a ‘relationship between transport and groove’; clicks of this nature aren’t really a central problem with MSP, triggering audio events using control signals IS.

I scanned your patch, and your original post and it’s still not clear to me what you’re trying to achieve with this patch: with looping turned off, and manually varying the ‘startloop’ inlet, you will be triggering the sample at that location – this WILL create clicks, but they are masked by your [function] envelope, the [metro]/[bang] combination is not a good choice for accurate and reliable tempo-synced triggering/looping; I recommend you check out [chucker~], [stutter~] and [techno~]. I believe there’s also something hiding in the /examples folder too.

Ensure your envelope begins and ends at zero.

If you could give us some pseudo code describing exactly what you expect from your patch then you’ll get loads of pointers.

Brendan

#211392
Sep 9, 2011 at 3:58pm

I don’t think this is an envelope-related issue. There is something strange in the relationship between groove~ and the transport.

Try the patch and you’ll see what I mean:
- set the transport tempo
- load a sample into the buffer (preferably a pitched note)
- set some steps in the sequence
- set the loop min on groove~ to something greater than 0. (30. ms, for example) – leave loop off (0)
- start the transport (space bar) and try changing the transport tempo

For some reason when the tempo is changed, groove~ jumps to the loop min point even though looping is turned off and the sample is being triggered from 0. This causes the clicking. If you set the loop min point to 0. the problem disappears. Of course you can use startloop but that eliminates the option of having a loop starting later in the sample.

Seems strange to me, but I’m quite sure that this is happening.

#211393
Sep 9, 2011 at 4:31pm

Hi Brendan,

Thanks for checking in. Sorry, I didn’t see your reply before my last post.

The patch is just a very stripped down illustration of the problem. The goal is to have a very simple sample player that can be driven from a step sequencer – for playing, say, synth samples. Manually changing the loopstart point is not a goal, but changing the transport tempo is. But there may be situations – sustaining a note, for example – where the loop will start later in the sample. Really basic stuff.

If you follow the steps above hopefully it will be clear what I’m referring to.

If the transport tempo is not changed this works perfectly for what I’m trying to do, but tempo change is a must.

Thanks!

#211394
Sep 9, 2011 at 5:12pm

Hi rham
thanks, this is much clearer! I’m not aware of any ‘issue’ between groove and transport – it would have popped up on this forum before – but there ARE some idiosyncracies with [groove~] behaviour; see here for example:

http://cycling74.com/forums/topic.php?id=30356

Here’s how to get ‘looping sampler’ behaviour from [groove~], without using the (startloop) message

– Pasted Max Patch, click to expand. –

EDIT improved version, but still very basic

Hopefully, you’ll be able to plug this in to your own sequencer; if the clicks continue when changing tempo, then I’ll be proved wrong :)

Brendan

#211395
Sep 9, 2011 at 7:39pm

Hi again, Brendan.

Yes, perhaps “issues” is a bit too pejorative!

I tried your patch with the same results. What seems most idiosyncratic to me is that this jumping to the loopstart point occurs even when looping is off.

Here’s a hopefully clear illustration – simple instructions on the left of the patch:

– Pasted Max Patch, click to expand. –

Anyway, it’s interesting. At least to me.

Maybe people don’t use groove~ in this way?

Thanks a lot for your help.

#211396

You must be logged in to reply to this topic.