Forums > MaxMSP

Has this happened to you?

September 12, 2007 | 11:43 pm

Ok so this may be a glitch in my specific machine, or a shortcut key I don’t know about, but I thought this was strange.
This is the third time this has happened, but that’s enough from me to think I must be doing it.

I am constructing in Max, I think I was copying objects with alt/option drag shortcut. All of a sudden I here a little sound played over my speakers like a "click click click" and then my mouse gets disabled. I use shortcut keys to go into my Universal Access control panel and somehow the function to use keyboard keys for mouse control has been enabled.
So has this happened to any of you?

Oh, buy the way, I am on a macbook pro 17" 2.33Ghz 2Gig memory on OS X 10.4.10 if that makes a difference.

Not a big problem, but strange no?


September 13, 2007 | 3:23 am

Hi,

I have a strange thing that happens very often when I am editing patches that sounds like your problem. Sometimes I can’t edit anymore. The mouse still mouves, but when I click on an object if just becomes gray and I can’t write. The only solution I have found is to quit max and restart.

Max 4.0.3 running in class. (This used to happen when I was running in os9.2.2 also.)


September 13, 2007 | 8:26 am

some other max UI weirdness:

I made some stand-alones which I use a lot to render things in the
background and there’s two things which happen very often but in
which I can not detect enough of a pattern in it to file a proper
bug report:

- very often my stand-alone application does not ‘accept’ the
keyboard focus when I click on one of its windows: I can click on
objects like ‘bang’, or on messageboxes and they often work, but the
window of the application does not come to the front and stays greyed
out. Clicking on messageboxes and ‘bangs’ does not always work,
however. The only way to get my stand-alone to get the proper UI
focus is to go into the dock and select the appropriate window of my
application there.
I suspect this weird behaviour could have something to do with the
dialog which appears when you use the ‘exportimage’ message of
jit.matrix: perhaps this dialog does not restore focus properly or
something ? But I could never pin it down exactly.

- recently I’ve had some instances of ‘Choose resume to restart the
scheduler’-alerts appear when i would press ‘apple-.’ while browsing
in Firefox. This is very weird.

all this on a macpro desktop machine, at the moment using max 4.6.2
and jitter 1.6.2, but these problems I’ve also seen with previous
versions…

does this sound familiar to anyone ?

ciao,

Joost.

On Sep 13, 2007, at 5:23 , Pierre-Emmanuel Levesque wrote:

>
> Hi,
>
> I have a strange thing that happens very often when I am editing
> patches that sounds like your problem. Sometimes I can’t edit
> anymore. The mouse still mouves, but when I click on an object if
> just becomes gray and I can’t write. The only solution I have found
> is to quit max and restart.
>
> Max 4.0.3 running in class. (This used to happen when I was running
> in os9.2.2 also.)

——————————————-

Joost Rekveld
———– http://www.lumen.nu/rekveld

——————————————-

"The question of whether a computer can think
is no more interesting than the question
of whether a submarine can swim."
(E. W. Dijkstra)

——————————————-


September 13, 2007 | 8:35 am

On 13 sept. 07, at 10:26, Joost Rekveld wrote:

> – very often my stand-alone application does not ‘accept’ the
> keyboard focus when I click on one of its windows: I can click on
> objects like ‘bang’, or on messageboxes and they often work, but
> the window of the application does not come to the front and stays
> greyed out. Clicking on messageboxes and ‘bangs’ does not always
> work, however. The only way to get my stand-alone to get the proper
> UI focus is to go into the dock and select the appropriate window
> of my application there.
> I suspect this weird behaviour could have something to do with the
> dialog which appears when you use the ‘exportimage’ message of
> jit.matrix: perhaps this dialog does not restore focus properly or
> something ? But I could never pin it down exactly.

Do you have All window active option checked? in a standalone you
have to uncheck the opetion in the inspector of the standalone object.

> – recently I’ve had some instances of ‘Choose resume to restart the
> scheduler’-alerts appear when i would press ‘apple-.’ while
> browsing in Firefox. This is very weird.

This is a normal behavior. Command+. is supposed to stop the scheduler.

ej


September 13, 2007 | 8:53 am


Viewing 5 posts - 1 through 5 (of 5 total)