Forums > Max For Live

Having A Problem Automating Preset Morphs

January 13, 2013 | 4:33 pm

Hello,

I am having a problem trying to automate preset morphing in Max 4 Live. I can automate preset changes but not preset morphing. When I try to automate the crossfade between presets I get a lot of MIDI slow down and tonnes of glitching. Here is a small patch highlighting the problem.

Does anybody know a way around this or can preset morphing not be automated in M4L. Although the patch was made in Max 6 there is nothing there that is not in Max 5.

– Pasted Max Patch, click to expand. –

January 13, 2013 | 4:47 pm

In my limited experience, this behaviour is not a suprise when interpolating presets that contain multiple parameters via M4L. I don’t know if this will solve your problem, but it may be worth increasing the ‘update limit’ parameter value for the automated morphing slider and see if the results are any better…


January 13, 2013 | 5:56 pm

@grizzle
your example seems to work for me. The zip-file contains a video of your patch being automated.

Max 5.1.9
Live 8.3.4
Windows XP SP3


January 13, 2013 | 7:37 pm

Thanks Spectro I gave it a go but it didn’t work.

Thanks Stan I tried in Max 5, i normally use Max 6 in M4L, but yes it works with Max 5… problem there somewhere.

I am still having a problem automating both Preset changes and Preset Morphing at the same time. I’ll keep bashing away at it but if anybody has any ideas the patch above is basically what I am using.


Viewing 4 posts - 1 through 4 (of 4 total)