Having trouble with a standard drum machine – trigging samples and timing

Jan 8, 2010 at 8:42pm

Having trouble with a standard drum machine – trigging samples and timing

Hey guys!

I’m making a patch to make a standard sort of drum machine, which obviously requires me to store some information. The drum machine is based on a 16 tick loop, so there are sixteen 0 and 1 values to store.

However, the ways that I’ve tried so far don’t trigger the samples with reliable regularity, and sometimes doesn’t trigger them at all.

I think the problem might be that I’m using max objects in my ‘signal chain’, which are polled too irregularly. I can’t think of a way of not using counter, or table/coll. Is that the problem? Do you know of any other options that might be available to me?

Best wishes,

Hugh

– Pasted Max Patch, click to expand. –
#47654
Jan 9, 2010 at 12:06am

i had no problems using your patch, but the way i have done it in the past has been with a multislider

#171342
Jan 9, 2010 at 4:19am

Hey, the_man,

When I use a hi-hat sound, for instance, and push the tempo as you might do for the hi-hat behind a drum and bass song, it becomes very, very obviously inaccurate. Does that not happen to you?

#171343
Jan 9, 2010 at 4:23am

I’ve been hooking up the timer object with the metro, a phasor-created square-wave-through-edge abstraction, and el.samm~ from Eric Lyons. No matter which I used, I still get the same result:

The bangs are irritatingly inaccurate. This inaccuracy is normally a fraction of a millisecond or a millisecond or two, but regularly are wildly more than that – the lastest attempt at 168 bmp varied between 370, 372 and 320.

This is driving me up the wall – is it just my computer (macbook, intel) or is it something else? I have had another maxer tell me that it ran okay on his computer. *shrug*

What I’m aiming for is to be able to stably bang so as to trigger a 16th note bar at a reasonable tempo in time.

#171344
Jan 9, 2010 at 4:28am

do you have overdrive turned on in dsp settings? the cycle timer should be accurate to drive the patch. i cant turn on speakers right now, but ill have a listen later if nobody else gets back :)

#171345
Jan 9, 2010 at 4:39am

I have Overdrive turned on in the options menu, but not ‘Scheduler in Overdrive’ in the DSP. I’ve turned that on too, but it doesn’t seem to yield better timing results.

Muchos grateful for the support, and sorry for the n00bishness!

Hugh

#171346
Jan 9, 2010 at 4:52am

Thankyou very much raja! I’ve just started to read up on the signal-vector size, and instantly heard the timing sorting out. I think I’m on the way to getting it done!

Many thanks to both you and the_man.

Hugh

#171348

You must be logged in to reply to this topic.