Hello

Aug 26, 2009 at 1:04pm

Hello

hello.

im trying to create a simple patch to emulate drum modules like the analog solutions concussor series.

im having an issue with the timing. the individual sounds are drifting out of phase with each other for some reason

can anyone shed any light on the situation?

– Pasted Max Patch, click to expand. –
#45235
Aug 26, 2009 at 2:02pm

The problem involves using multiple metronomes – they’re all free-running, so they’ll drift. There are several solutions to investigate: Using phasor~/rate~ object pairs and a little logic to send bangs on the end of the phasor~ ramp was what everyone used to use, but now you have the ability to slave metronomes to a global transport in Max, which means that they all stay in sync with each other and can be set using musically “meaningful” time. Take a look at Max tutorial 19 and the helpfiles for the metro and transport objects. Both of those solutions work and you can decide what you want to use.

#163001
Aug 26, 2009 at 2:05pm

Don’t have too much time, also don’t know much about audio, but one thing i’d do is use one metro instead of multiple. Makes sure that part stays in sync.

– Pasted Max Patch, click to expand. –
#163002
Aug 26, 2009 at 2:09pm

Welcome, Mike. You’re probably experiencing timing issues due to the [metro] object which is based on the Max scheduler. Look at Tutorial 19: Timing for info on using the [transport] object instead which will provide more solid timing.

If you want to delve into the Max scheduler, overdrive, etc. you can explore the options in the Scheduler pane of the Max Preferences window.

At some point you might also look into syncing events using audio-rate objects. There are plenty of good posts on the forum that cover this topic.

#163003
Aug 26, 2009 at 3:39pm

done a bit of editing to the patch

sounds like it has been improved – can anyone confirm that this sounds tighter? thanks

– Pasted Max Patch, click to expand. –
#163004

You must be logged in to reply to this topic.