Forums > MaxMSP

Help a beginner? Trying to record audio, then play it back forwards and backward

December 6, 2012 | 7:56 pm

Hi everyone,

I learned the basics of Max/MSP a long time ago, but unfortunately haven’t used it since then and have forgotten pretty much everything. I’m trying to get back into the swing of it now.

I’m trying to make a really simple patch to record audio files, then play them back, both forwards and reversed. I imagine I should be using sfplay~ and sfrecord~ for this. How can I make sfplay~ automatically load the file I just recorded with sfrecord~? I don’t want the user to have to click ‘open’ and find the file.

Also, I get how to do reverse playback with sfplay~, but how can I make it start from the end of the file? I’d like it to automatically start at the beginning when normal playback is selected, and automatically start at the end when reverse playback is selected. Seems like it should be simple, but I’m just not seeing it…

Sorry to have to ask such basic questions, and thanks in advance for any help with this!



dtr
December 6, 2012 | 8:07 pm

You wanna look at the buffer~ object.


December 6, 2012 | 9:18 pm

In addition to buffer~, groove~ will be helpful, I think.


December 6, 2012 | 9:40 pm

Hi, thanks for responding.

I was looking at buffer~ before, but I was under the impression that you had to specify the length in milliseconds each time you record. For these recordings I was hoping to have it just record as long as you want (from when you press ‘start’ to ‘stop’) and then be able to play back that sound file.

Can buffer~ do that?


December 6, 2012 | 10:01 pm

search the forum, it has so much information and so many answers

http://cycling74.com/forums/topic.php?id=12128


December 6, 2012 | 10:09 pm

Thanks for the link.

The main recommendation there was to use sfrecord~, which is what I said I was thinking of using in my first post (before someone said to use buffer~). But that brings me back to my first question, about having the recording automatically load into sfplay~…


December 6, 2012 | 10:28 pm

use buffer and groove…you don’t need to specify ahead of time you record length.


December 7, 2012 | 1:01 am

Really? buffer~ is working fine when I specify the record length, but when I don’t add that part it doesn’t seem to record. Any ideas why this would be?


December 7, 2012 | 2:05 am

OK, I ended up just setting the buffer~ length much longer than I needed to record. If there’s a better way to do it (so that the buffer~ length is automatically adjusted to be the recording length), I’d love to hear it. But it seems to be working like this, at least for what I want to do this time.

Thanks for the advice!



December 12, 2012 | 1:49 am

Thanks for the link Chris. I really like how you linked the images to the patcher file. Works very well.


Viewing 11 posts - 1 through 11 (of 11 total)