Help me !!! probleme to compiling with xcode 2.5 and tiger 10.4.11

May 1, 2009 at 12:07pm

Help me !!! probleme to compiling with xcode 2.5 and tiger 10.4.11

I work on macintel with max 5 xcode 2.5 anf tiger 10.4.11, i don’t want switch to leopard; i have listen the tuto http://www.cycling74.com/story/2005/10/5/82341/3928 to compiling with xcode and max4.6; i again tried to compiling the exemples xcodeproj in maxsdk 5.0.6 like plussz … unsucessful!

anyone have the same probleme ???
anyone have a tutorial for this configuration or the list of things i must doing ????

ps: sorry for my english … i’m french…

#43621
May 1, 2009 at 2:12pm

Well, I’m afraid cycling74 will actually support the SDK only XCode3 (meaning Leopard). The tutorial you are referring to is from 2005. The recent SDK is to be used with XCode 3.
I suggest you ask such questions on the Dev forum. Someone may help you figure that out there.
J-F.

#156511
May 1, 2009 at 3:45pm

hello maxers,

i have problems too, as i have same config as you (tiger 10.4.11 and Xcode 2.5).

Actually i haven’t investigate more cause i spend time with javascript, but as i would like to learn C ; soon ; i’m interesting to know more about that.

#156512
May 2, 2009 at 4:46pm

Hello,

i solved the problem i had with last SDK (Max 5 updated 10 february), max 5.0.7, osX 10.4.11, Xcode 2.5 ;

I have just edited the maxmspsdk.xcconfig file :

I had :

SDKROOT[arch=i386] = /Developer/SDKs/MacOSX10.4u.sdk
SDKROOT[arch=ppc] = /Developer/SDKs/MacOSX10.4u.sdk
GCC_VERSION[arch=i386] = 4.0
GCC_VERSION[arch=ppc] = 4.0

I keep :

SDKROOT = /Developer/SDKs/MacOSX10.4u.sdk
GCC_VERSION = 4.0

I don’t know why, but that’s work. Please tell me if i’ve done something awfully dangerous for my computer Smile

#156513
May 3, 2009 at 10:39am

Hello,

I’ve just tried your solution and it’s ok!!!!
Congratulation !!!
I’ve this probleme for two month …
I’m very happy !

Thank you !

#156514

You must be logged in to reply to this topic.