Help porting pd's [rev3~] to max/msp

Nov 2, 2008 at 1:39pm

Help porting pd's [rev3~] to max/msp

I am trying to recreate the puredata reverb abstraction [rev3~] in max/msp5. I am having some problems that I can’t solve.

My max version will feedback, growing out of control. This does not happen in the Pd original. I think that I have faithfully recreated the patch in Max. Obviously, I’ve done something wrong.

The problem occurs when the “liveness” setting goes above 88 or so.

The puredata rev3~ abstraction I’m using as a model comes from PD-Extended_0.40.3. I’m using Max/MSP_5.0.5.

Any help fixing this would be greatly appreciated. I’ve attached the Max abstraction and a file to test the abstraction with.

Thanks,
Mitch

#40614
Nov 4, 2008 at 2:40pm

bump

#143807
Nov 4, 2008 at 9:16pm

On 04 Nov 2008, at 15:40, Mitch Turner wrote:
>
> bump
> –
>

you got two wrong connections in the decorrelation network, that
spoil the whole thing.
it’s in the first of 4 blocks (the second + and i), right after the
feedback layer.
if you look at the graphical pattern the crossing patchcords make,
you can find it easily.

volker.

#143808
Nov 5, 2008 at 10:25am

Mitch Turner schrieb:
> bump

it shouldn’t be that hard, just take delwrite~/delread~ as
tapin~/tapout~ and basically rebuild it object by object. You might want
to look into my St.ools, there is a bunch of Pd abhaXions in it (lop~
and moses come to mind though its far from complete…)

But also look into the examples folder, I think there might reside a
better reverb~…

Good luck, and share the result…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#143809
Nov 5, 2008 at 5:04pm

#143810

You must be logged in to reply to this topic.