hi object and multiple hid devices

Oct 14, 2006 at 8:01pm

hi object and multiple hid devices

Hi everyone.
I’m wondering if it’s possible to get data into max from multiple hid devices at the same time using the hi object? All the devices are plugged into a usb hub and are detected by the hi object. But so far my experience is that the hi object only seems able to focus on one device at a time. Is there some way to resolve this? Alternatively, is there another hid object available that doesn’t have this limitation? Or, am I missing something obvious???
Thanks a lot!

Dan.

#28147
Oct 14, 2006 at 8:15pm

Hi!

How about using two hi, one for each object? As long as the hi object is capable of identifying each object as a single entity, of course…

Best regards,

Rui

#86114
Oct 14, 2006 at 8:29pm

I tried that…. But I got the impression that it wasn’t working. Do you have experience with it working?

#86115
Oct 14, 2006 at 9:03pm

Quote: Daniel Grigsby wrote on Sat, 14 October 2006 22:01
—————————————————-
> Hi everyone.
> I’m wondering if it’s possible to get data into max from multiple hid devices at the same time using the hi object? All the devices are plugged into a usb hub and are detected by the hi object. But so far my experience is that the hi object only seems able to focus on one device at a time. Is there some way to resolve this? Alternatively, is there another hid object available that doesn’t have this limitation? Or, am I missing something obvious???
> Thanks a lot!
>
> Dan.
—————————————————-

I have had the same experience. I now use the Joystick external from maxobjects.com instead.

#86116
Oct 14, 2006 at 9:16pm

crap, but that’s a windows only external!

#86117
Oct 14, 2006 at 9:38pm

I recently used HI in a performance to watch 4 game controllers simultaneously, using 4 separate instances of HI. It always worked as expected. You might test this by loading multiple instances of the help patch.

#86118
Oct 14, 2006 at 9:44pm

Yep… multiple instances of help patch: works here. 4.5 on Pb G4/10.4.7

#86119
Oct 14, 2006 at 10:06pm

were you using a usb hub? I assume you would be with 4 devices!

#86120
Oct 14, 2006 at 10:13pm

Yes, which brings up another potential issue: with multiple power-sucking devices, if the hub is not itself powered, you may run into power issues. if this is a problem, the devices will simply not show up in your hi menu.

#86121
Oct 14, 2006 at 10:48pm

Thanks for the feedback everyone. I’ll try again tomorrow as I don’t have all the devices with me. Thanks again.
Dan.

#86122

You must be logged in to reply to this topic.