Forums > MaxMSP

HID output and bugfixes for [hi] object

March 21, 2007 | 3:44 pm

Okay, since David Z. said they would not improve the hi object for the
next Max release and since everybody is asking for HID output… and
because I’m tired of sending it to everybody off-list here the official
download for the [hid] object:

http://www.akustische-kunst.org/maxmsp/download/hid-1.0beta3-wmax.zip

As the name says THIS IS A BETA RELEASE!!!! Will probably crash sooner
or later or not work with your device…. so in case you have any
trouble, report to my email address (off-list).

Output has been tested with a force-feedback gamepad and with Dan
Overholt’s CUI interface.
Keyboards and mice not supported, because Mr. Bill Gates wants it like that.

THIS IS WINDOWS ONLY! EMAILS ASKING FOR A OS X VERSION WILL BE IGNORED!
I will probably make a OS X version sooner or later, most likely _later_!

Olaf


March 21, 2007 | 6:28 pm

My hat’s off to you; this object is already indispensable to my senior project! Many many thanks.


March 23, 2007 | 8:47 pm

sorry for the pretty much repeat topic.

Can you use multiple HID objects running different interfaces. i’ve tried and keep getting lots of fun crashs. I’ve tried just the single joysticks etc but i cannot use more than one.

any suggestions.
does anyone know why the HI object can’t find all 4 of my devices as well and only the first one.

cheers folks


March 23, 2007 | 8:53 pm

Hello,
You might try updating to the current version of MaxMSP available from
our website.

Cheers,
Andrew B.


March 23, 2007 | 9:29 pm

Macca wrote:
> sorry for the pretty much repeat topic.
>
> Can you use multiple HID objects running different interfaces.

Just to make sure you’re dong the right thing: with ‘hid’ you have to
open devices by number if you have more than one of the same type
becasue the names of the devices in the menu would be the same and thus
always open the first devide with that name. You can klick the ‘print’
message box to get a list of devices with their numbers.
In case it still crashes please let me know (off-list).

Olaf


March 23, 2007 | 10:29 pm

Heya…kinda solved it…kind of anyway. I installed the demo of max 4.6 and the hi object lets me use all 4 of my controllers at once. which is really really good. But when i use hid it still crashes. i tried doing the different numbers. I shall ahve another go at one point but i can use the hi object now to actully finish my uni assignment. Thank you for the 4.6 advice…i shall buy the upgrade etc when my next student loan comes in. Cheers guys


Viewing 6 posts - 1 through 6 (of 6 total)