Hide message window in Windows standalone

Mar 5, 2009 at 4:47pm

Hide message window in Windows standalone

Af far as I can tell, this is the current way to hide the message window in Max5 – Can anyone shed light on why it isn’t working. I’m making a standalone using the Windows version of Max 5.0.6, in Windows XP in bootcamp on Macbook pro. Thanks.

#42682
Mar 5, 2009 at 10:41pm

Perhaps because you’re setting the visibility of the window “at startup” via loadbang after the standalone has already been started. Try opening the [standalone] object inspector and simply de-selecting the “status window visible” option and then saving your patch then creating a standalone and see if it works.

lh

#152799
Mar 6, 2009 at 2:42am

That worked on the example, thanks.
The only problem is didn’t work when I tried to incorporate it into the actual patch i’m working on. Here I’ve included the thispatcher bits that seem to disable it.

{
“boxes” : [ {
"box" : {
"maxclass" : "message",
"text" : "window size 100 100 487 747, window exec",
"patching_rect" : [ 66.0, 386.0, 236.0, 18.0 ],
“hidden” : 1,
“numinlets” : 2,
“fontname” : “Arial”,
“numoutlets” : 1,
“outlettype” : [ "" ],
“id” : “obj-26″,
“fontsize” : 11.595187
}

}
, {
“box” : {
“maxclass” : “message”,
“text” : “window flags nogrow, window exec”,
“patching_rect” : [ 79.0, 364.0, 190.0, 18.0 ],
“hidden” : 1,
“numinlets” : 2,
“fontname” : “Arial”,
“numoutlets” : 1,
“outlettype” : [ "" ],
“id” : “obj-18″,
“fontsize” : 11.595187
}

}
, {
“box” : {
“maxclass” : “message”,
“text” : “window flags grow, window exec”,
“patching_rect” : [ 145.0, 414.0, 177.0, 18.0 ],
“hidden” : 1,
“numinlets” : 2,
“fontname” : “Arial”,
“numoutlets” : 1,
“outlettype” : [ "" ],
“id” : “obj-19″,
“fontsize” : 11.595187
}

}
, {
“box” : {
“maxclass” : “newobj”,
“text” : “loadbang”,
“patching_rect” : [ 66.0, 207.0, 60.0, 20.0 ],
“hidden” : 1,
“numinlets” : 1,
“fontname” : “Arial”,
“numoutlets” : 1,
“outlettype” : [ "bang" ],
“id” : “obj-8″,
“fontsize” : 12.0
}

}
, {
“box” : {
“maxclass” : “message”,
“text” : “window notitle, window exec”,
“patching_rect” : [ 101.0, 280.0, 156.0, 18.0 ],
“hidden” : 1,
“numinlets” : 2,
“fontname” : “Arial”,
“numoutlets” : 1,
“outlettype” : [ "" ],
“id” : “obj-5″,
“fontsize” : 11.595187
}

}
, {
“box” : {
“maxclass” : “message”,
“text” : “window title, window exec”,
“patching_rect” : [ 168.0, 436.0, 151.0, 18.0 ],
“hidden” : 1,
“numinlets” : 2,
“fontname” : “Arial”,
“numoutlets” : 1,
“outlettype” : [ "" ],
“id” : “obj-44″,
“fontsize” : 11.595187
}

}
, {
“box” : {
“maxclass” : “newobj”,
“text” : “thispatcher”,
“patching_rect” : [ 118.0, 464.0, 69.0, 20.0 ],
“hidden” : 1,
“numinlets” : 1,
“fontname” : “Arial”,
“numoutlets” : 2,
“outlettype” : [ "", "" ],
“id” : “obj-7″,
“fontsize” : 12.0,
“save” : [ "#N", "thispatcher", ";", "#Q", "window", "flags", "nogrow", "close", "zoom", "nofloat", "menu", "minimize", ";", "#Q", "window", "constrain", 2, 2, 32768, 32768, ";", "#Q", "window", "size", 100, 100, 487, 773, ";", "#Q", "window", "notitle", ";", "#Q", "window", "exec", ";", "#Q", "savewindow", 1, ";", "#Q", "end", ";" ]
}

}
, {
“box” : {
“maxclass” : “message”,
“text” : “bgcolor 1. 1. 1 0.”,
“patching_rect” : [ 118.0, 257.0, 117.0, 18.0 ],
“hidden” : 1,
“numinlets” : 2,
“fontname” : “Arial”,
“numoutlets” : 1,
“outlettype” : [ "" ],
“id” : “obj-16″,
“fontsize” : 12.0
}

}
, {
“box” : {
“maxclass” : “comment”,
“text” : “TEST”,
“patching_rect” : [ 47.0, 49.0, 327.0, 41.0 ],
“frgb” : [ 1.0, 1.0, 1.0, 1.0 ],
“textcolor” : [ 1.0, 1.0, 1.0, 1.0 ],
“numinlets” : 1,
“fontname” : “Arial”,
“numoutlets” : 0,
“id” : “obj-1″,
“fontsize” : 30.0
}

}
, {
“box” : {
“maxclass” : “newobj”,
“text” : “standalone”,
“patching_rect” : [ 51.0, 114.0, 69.0, 20.0 ],
“numinlets” : 1,
“fontname” : “Arial”,
“numoutlets” : 0,
“id” : “obj-20″,
“fontsize” : 12.0,
“saved_object_attributes” : {
“preffilename” : “Max 5 Preferences”,
“statusvisible” : 0,
“searchformissingfiles” : 1,
“allwindowsactive” : 0,
“audiosupport” : 1,
“noloadbangdefeating” : 0,
“overdrive” : 0,
“cantclosetoplevelpatchers” : 1,
“midisupport” : 0,
“usesearchpath” : 0
}

}

}
, {
“box” : {
“maxclass” : “panel”,
“varname” : “autohelp_top_panel”,
“patching_rect” : [ 7.0, 10.0, 373.0, 619.0 ],
“rounded” : 100,
“numinlets” : 1,
“mode” : 1,
“grad1″ : [ 0.0, 0.0, 0.0, 0.698039 ],
“numoutlets” : 0,
“grad2″ : [ 0.0, 0.0, 0.0, 0.698039 ],
“background” : 1,
“id” : “obj-6″
}

}
],
“lines” : [ {
"patchline" : {
"source" : [ "obj-5", 0 ],
“destination” : [ "obj-7", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-44", 0 ],
“destination” : [ "obj-7", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-16", 0 ],
“destination” : [ "obj-7", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-8", 0 ],
“destination” : [ "obj-5", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-8", 0 ],
“destination” : [ "obj-16", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-8", 0 ],
“destination” : [ "obj-18", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-18", 0 ],
“destination” : [ "obj-7", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-19", 0 ],
“destination” : [ "obj-7", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-26", 0 ],
“destination” : [ "obj-7", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
, {
“patchline” : {
“source” : [ "obj-8", 0 ],
“destination” : [ "obj-26", 0 ],
“hidden” : 1,
“midpoints” : [ ]
}

}
]
}

#152800
Mar 6, 2009 at 10:10am

That patch works as I would expect when I build it into an .app on 10.4.11 and 5.0.4. No status window when it’s opened. Perhaps it’s a windows or bootcamp problem? Are you experiencing any other issues when building windows standalones?

lh

#152801
Mar 6, 2009 at 12:41pm

Yes, there are a few, namely the timer object doesn’t work and jitter’s 2dtext draws blocks on carriage returns. Everything I’m doing in Max at the moment has to be delivered as a Windows standalone.

#152802
Mar 6, 2009 at 1:19pm

Then you might need to try compiling your standalone on a windows machine rather than using bootcamp. I’m no expert but this might be the cause of your problems. Sorry I can’t be of more help.

lh

#152803
Mar 6, 2009 at 7:12pm

the jit.gl.text2d issue would seem to indicate that you have an older version installed. I’d do a clean wipe using add/remove and re-download:

http://cycling74.com/downloads/max5

All the best,
-Ben

#152804
Mar 8, 2009 at 3:34am

Hi Ben, that’s good news – sorry, I hadn’t tested it recently. Do you have any suggestions as to what might be overriding the standalone objects “status window visible” option.

#152805

You must be logged in to reply to this topic.