Forums > MaxMSP

hidecursor message problem

July 15, 2009 | 7:26 pm

message ‘;max hidecursor $1′returns the alert (yellow)

max: extra arguments for message "hidecursor"

same beaviour with ‘showcursor’.

and, after the first call, it doesn’t work anymore.

Could anyone confirm this?

Thanks

maxmsp 5.0.7
jitter 1.7
osx 10.5.7

matteo



MIB
July 15, 2009 | 7:34 pm

get rid of the $1:

– Pasted Max Patch, click to expand. –

July 15, 2009 | 10:27 pm

many thanks!

Cycling have to change documentation…


July 15, 2009 | 10:45 pm

Thanks for noticing, it has been fixed for the next incremental.


July 16, 2009 | 2:25 am

Is there a constrain cursor message to keep the cursor from moving outside a certain area?

Such as when using the show/hide cursor message to make a custom mouse roll-over cursor for a multislider – so the new cursor can’t go outside the multislider with the mouse down.


July 16, 2009 | 12:23 pm

There’s no constrain per se, but you can achieve that by using the ; max pupdate message.


April 11, 2012 | 11:32 pm

I am trying to hide the cursor in a standalone which includes a vst~ plugin object loaded with Kontakt 4. I am running the standalone on a touchscreen so do not want the mouse visible at all.

The "hidecursor" message works great until I ask Kontakt to load a new multi (an fxp file). As soon as the progress bar appears and Kontakt is loading then the mouse cursor re-appears and will not let me hide the cursor until its finished loading.

Is there a way of keeping the cursor hidden at all times?


Viewing 7 posts - 1 through 7 (of 7 total)