Hiding/Spaces Max 5 in OS 10.5…bug?

May 18, 2008 at 12:21pm

Hiding/Spaces Max 5 in OS 10.5…bug?

Here’s another problem I’ve encountered with Max 5…I’m running Max 5.0.2 on Mac OS 10.5.2, and I’m using Spaces. I have all of my audio apps set to open in one Space, and all my internet apps in another.

The problem is, when I am using Max 5 and I try to hide it, using command+H, the application stays visible. Then if I switch to another application in another Space (Safari, for instance), Max 5 disappears. It is impossible to get back to the project I was working on in Max 5…the application is still open, but the windows are hidden and won’t come back, even if I manually switch to the audio Space. My only solution is to force quit Max 5 (and lose anything I didn’t save) :(

Anyone else have this problem? Any suggestions for a workaround?

#37859
May 18, 2008 at 7:22pm

I can’t reproduce this with 5.0.2 and 10.5.2. [command + H] works just fine for hiding here. Have you tried using the [command + tab] command to select Max after it’s disappeared? That is one way to unhide a hidden app. Another is to click on its icon in the dock. Sorry if that’s too obvious but I don’t know what you’ve tried.

#131103
May 27, 2008 at 12:07pm

I believe that due to some of the cool things M5 does with its
windows, it is not Spaces-friendly. Personally, after a 48-hour
flirtation, I found Spaces to not be terribly Spaces-friendly…..

M

On May 18, 2008, at 15:22, David Huff wrote:

>
> I can’t reproduce this with 5.0.2 and 10.5.2. [command + H] works
> just fine for hiding here. Have you tried using the [command + tab]
> command to select Max after it’s disappeared? That is one way to
> unhide a hidden app. Another is to click on its icon in the dock.
> Sorry if that’s too obvious but I don’t know what you’ve tried.

#131104
May 27, 2008 at 12:44pm

#131105
May 27, 2008 at 1:26pm

Well, I’m glad that other people are having trouble too. I can’t seem to recreate my problem consistently, it only seems to break when I need it most :) I can’t find any real pattern for it yet, it just seems to happen every so often when I’m careless about my hiding and spaces.

Oh, and the alt+Tab trick doesn’t work. argh!

#131106
May 27, 2008 at 5:37pm

On May 27, 2008, at 6:26 AM, Yann Seznec wrote:

> Well, I’m glad that other people are having trouble too. I can’t
> seem to recreate my problem consistently, it only seems to break
> when I need it most :) I can’t find any real pattern for it yet, it
> just seems to happen every so often when I’m careless about my
> hiding and spaces.
>
> Oh, and the alt+Tab trick doesn’t work. argh!

I’ve found that the trick with Spaces is to hard assign frequently
used apps to their own places in System Preferences. Once I did that,
my troubles were far fewer. Now I can be in any Space, open a .maxpat
and the view automagically shifts to Max 5′s assigned Space. If you
run Max with the Clue window open, you’ll need to click the desktop
and back into Max before it shows up, but other than that it works
pretty well for me. I generally have a square of 9 spaces running
with specific apps assigned by task type in each.

There are apps that are Spaces unhappy, though. Adobe CS3, Final Cut
are a couple of the standouts, but even these are better behaved when
hard assigned.

Vlad

Vlad Spears
Tanj! I’m already out of Known Space!

http://www.daevlmakr.com

http://www.2secondfuse.com

#131107

You must be logged in to reply to this topic.