How can audio inputs be changed live?

Jun 16, 2008 at 5:07pm

How can audio inputs be changed live?

I want to be able to control what soundcard channel audio comes into my patch from, inside the patch. I thought this would work, using adstatus outputs and set messages:

– Pasted Max Patch, click to expand. –

However, that only works if I do the following steps:
Enable dac~
Select inputs
Disable dac~
Enable dac~

After doing those steps once the dac~ no longer has to be switched on and off, but it seems like there should be a simple way without ever disabling the dac~.

#38437
Jun 16, 2008 at 5:38pm

you could just route it after the [adc~]

#134105
Jun 16, 2008 at 6:36pm

here you go:

– Pasted Max Patch, click to expand. –

On Mon, Jun 16, 2008 at 6:38 PM, don malone wrote:
>
> you could just route it after the [adc~]
> –
> it takes all of us
> LoneMonad
> http://faculty.roosevelt.edu/malone/default.htm
>

#134106
Jun 16, 2008 at 6:59pm

oh yeah in the example I gave you might get clicks so you might want
to use the routing option or some sort of de-clicker

On Mon, Jun 16, 2008 at 7:36 PM, carey dodge wrote:
> here you go:
>
>

– Pasted Max Patch, click to expand. –

>
>
> On Mon, Jun 16, 2008 at 6:38 PM, don malone wrote:
>>
>> you could just route it after the [adc~]
>> –
>> it takes all of us
>> LoneMonad
>> http://faculty.roosevelt.edu/malone/default.htm
>>
>

#134107
Jun 16, 2008 at 7:42pm

That patch has the same problem as my patch: I have to turn off audio and then turn it back on or else it doesn’t work.

#134108
Jun 16, 2008 at 9:57pm

really? I have used it in many patches and it works fine. huh?

Go with the route option then:

– Pasted Max Patch, click to expand. –

or if you want to get fancy you can look into poly~
On Mon, Jun 16, 2008 at 8:42 PM, Aaron Faulstich wrote:
>
> That patch has the same problem as my patch: I have to turn off audio and then turn it back on or else it doesn’t work.
>
>

#134109
Jun 16, 2008 at 11:58pm

I did “new from clipboard” with your patch (the first one), then:

enabled adc~
changed the number box to 3

On my system that doesn’t do anything unless I then:

disable adc~
enable adc~

Then it works. Does the patch I posted work on your system?

#134110
Jun 18, 2008 at 8:02am

Aaron Faulstich schrieb:
> I want to be able to control what soundcard channel audio comes into my patch from, inside the patch. I thought this would work, using adstatus outputs and set messages:

You could copy the I/O subpatcher from the DSP status patch, or just use
the DSP status…


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#134111

You must be logged in to reply to this topic.