Forums > MaxMSP

How can I fix a Window that disappears Off Screen? (mac)

June 8, 2007 | 1:53 pm

Hi,

I’m running a new installation of MAX/msp and the output window does not appear on my monitor. When I use exspose the window comes in to view but when I click on it it disappears off screen to the left, therefore I can’t grab it with my mouse.

I think the problem stems from when I was using dual monitors, one of which burned out so I am now only using one.
So far I’ve moved to the desktop all the MAX/msp preferences that I can find.

com.cycling74.MaxMSP46.plist
com.cycling74.MaxMSPRuntime46.plist
com.cycling74.MaxMSP46.plist

I’ve looked in System Preferences – Displays – This shows that my mac only expects to see my single monitor.

I remember in OS9 there was a key command to allow you to move windows without the use of a mouse – If there’s one for OSx it would probably solve my problem but I can’t find it. :-(

I’m using a G4 dual 867 OSX 10.4.7 with a SyncMaster920n monitor

Any help appreciated

James


June 8, 2007 | 1:56 pm

Menu: window -> alt + click window of your choice


June 8, 2007 | 1:59 pm

Thank you soooooo much.

….now to glue my hair back on

James


June 8, 2007 | 10:56 pm

HAHAHA!!! I used to have this problem all the time at school. I’d create the max project on dual monitors, forget to drag the main window back,and then look like a fool in front of my classmates when i couldn’t use or explain my patches during presentations. It happened way too many times.

Anywas. thanks for the keyboard shortcut…. too bad i didn’t know that before…


June 9, 2007 | 11:40 am

It caused me a lot of trouble too before it occured to me I could ask this on the forum.

Mattijs

Quote: selalou10@yahoo.com wrote on Sat, 09 June 2007 00:56
—————————————————-
> HAHAHA!!! I used to have this problem all the time at school. I’d create the max project on dual monitors, forget to drag the main window back,and then look like a fool in front of my classmates when i couldn’t use or explain my patches during presentations. It happened way too many times.
>
> Anywas. thanks for the keyboard shortcut…. too bad i didn’t know that before…
>
>
>
>
—————————————————-


June 9, 2007 | 1:01 pm

I also had the problem when switching from dual monitor to single monitor configuration. In:

/users/yourself/library/preferences/Max4.6 preferences folder

you will find a lot of interesting files. Open maxoptions.txt and you can edit the position of each max window. Of course, do it before launching Max.

A somewhat similar question: when opening an OS X patcher that have been created on a WinXP machine, I cannot drag some subpatchers, since in windowsXP you can have windows at the very top of the screen, – not possible on OS X due to the finder menu.

The only way I found to catch those windows is to edit the text version of the patch, looking for the coordinates to change under the vpatcher lines itens. Not very quick. So my question:

Can you drag a window under OS X without any access to the top bar of the window ?

Domi


June 9, 2007 | 2:29 pm

> A somewhat similar question: when opening an OS X patcher that have been created on a WinXP machine, I cannot drag some subpatchers, since in windowsXP you can have windows at the very top of the screen, – not possible on OS X due to the finder menu.
>

Put the following spell "; max hidemenubar" in a message box and click on it. You will probably also want the companion spell "; max showmenubar" when you’ve finished.

mz


June 9, 2007 | 3:38 pm

Thank you. I knew that max command, but I had not the idea to use it.


Viewing 8 posts - 1 through 8 (of 8 total)