How can i solve this problem ?

Nov 4, 2011 at 6:58am

How can i solve this problem ?

Hello maxers,

ONLY THE FIRST TIME (after switched on my computer and launched maxMSP) a function is called in my patch a short break in scheduler timing occurs ; is it a problem with paging or something like that ? ; IMHO that comes from “dump” message in my external and outlet_anything ; the only solution i found for now is to warm up my external ; but that’s not elegant.

So :

Did you know a way / a tool to track exactly where the problem happens ?
Do you have the problem on your computer (Zipped patch join) ?

if you have time and are super nice guy maybe a look on my code ? ;-)

any help/idea appreciate, thanks.

#59784
Nov 4, 2011 at 6:58am

oops

Attachments:
  1. warmup.zip
#215167
Nov 4, 2011 at 8:26am

Hi vanille

I can’t reproduce your problem… actually, I didn’t make a clean start of the machine – just restarted Max

Anyway, the scheduler doesn’t stumble here (MBP 2.4 GHz, OSX 10.6.8, MMJ 5.1.9) – what is your configuration? have you tried toying with the various scheduler settings? mine are just the default, but one never knows…

aa

#215168
Nov 4, 2011 at 12:32pm

Hello,

problem occurs only first time i start maxMSP (after shutting down) and not everytime ;-)

i did few more test, and it seems that’s happened not only with “dump” message, but “november” too (if i didn’t warmup the function first) …

i test whit forcing malloc allocation in my code (as on LINUX i read that the memory can be virtually allocated) but nothing change …

i don’t think it is a mutex locking problem as i implement my own mutex (POSIX one) in my stuff and it happens ONLY the first time !

so i suspect a paging fault or something like that ; but i’m not experienced enough to fully understand how to track and see it ; i mean i tried with SHARK and so but except statistic i found nothing ; and i’m not sure at all it is that …

i could change scheduler slop; but i would like to find a solution user friendly so i prefer to keep them to default.

mac OS X.4.11 / maxMSP 5.1.9

#215169
Nov 4, 2011 at 3:13pm

Hello,

so after investigations it seems “november” is the problem ; that’s a cellular automata like algorithm ; it’s the more heavy for CPU (around 0.3 ms) ; the problem occurs only the first time i call the function after switch on the computer ; if i quit and reload maxMSP application the problem doesn’t occurs …

#215170
Nov 4, 2011 at 4:50pm

Hello,

okay, happens with others messages too : headache.

#215171
Nov 4, 2011 at 8:48pm

That used to happen to me too. Whatever action I took in the very first patch I opened, I would always get scheduler problems.

I simply disabled the scheduler and that solved it.

#215172
Nov 5, 2011 at 9:29am

Hello,

do you mean “overdrive” ? ;
for me that’s not an issue as i need accurate timing.

I’ll try to write smallest code ; improve mutex contention …
That’s heavy computations ask at the same time, and i suspect it is too much when “instruction cache” is “empty” …

but that’s noob assumptions ;-)

and it seems there is no tool to confirm that ;
anybody use “Valgrind” on OS X ?
is it useful ?

#215173

You must be logged in to reply to this topic.