How connect a poly~ to matrix~ ?…

Apr 22, 2007 at 10:08am

How connect a poly~ to matrix~ ?…

The newbie question…

How do you name this problem ? Overhead ?

I want to connect a lot of poly~ directly in a matrix~, without the combo send~/receive~. I did that with abstraction with a couple of tapin~/tapout~ before the outlet, but inside a poly~, tapin~/tapout~, strangely, doesn’t work… humhum…

What is the tip ?
(except waiting max 5…)

(for example : with a poly~ named “my_poly” like this:

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#N out~ 1;
#P newobj 22 78 39 196617 out~ 1;
#N in~ 1;
#P newobj 23 46 33 196617 in~ 1;
#P window clipboard copycount 2;

and a patcher like this:

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P message 194 90 37 196617 0 0 1.;
#P newex 163 173 31 196617 dac~;
#P newex 163 56 31 196617 adc~;
#P newex 163 132 77 196617 matrix~ 2 2 1.;
#P newex 196 172 97 196617 poly~ my_poly 1;
#P connect 1 1 0 0;
#P connect 0 0 1 1;
#P connect 4 0 1 0;
#P connect 2 0 1 0;
#P connect 1 0 3 0;
#P window clipboard copycount 5;

this doesn’t work.
and if I modify “my_poly”:

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 23 98 44 196617 tapout~;
#P newex 23 73 59 196617 tapin~ 100;
#N out~ 1;
#P newobj 23 132 39 196617 out~ 1;
#N in~ 1;
#P newobj 23 46 33 196617 in~ 1;
#P connect 2 0 3 0;
#P connect 3 0 1 0;
#P connect 0 0 2 0;
#P window clipboard copycount 4;

it’s the same problem.)

#31524
Apr 22, 2007 at 11:11am

On 22 avr. 07, at 12:08, Thomas Goepfer wrote:

> The newbie question…
>
> How do you name this problem ? Overhead ?
>
> I want to connect a lot of poly~ directly in a matrix~, without the
> combo send~/receive~. I did that with abstraction with a couple of
> tapin~/tapout~ before the outlet, but inside a poly~, tapin~/
> tapout~, strangely, doesn’t work… humhum…
>
> What is the tip ?

You’ll have to put the tapin~/tapout~ outside the poly~ object.

ej

#102617
Apr 22, 2007 at 11:26am

yes, it’s a solution (and it works !…).
It’s the only solution ?…

#102618
Apr 23, 2007 at 11:53pm

On Apr 22, 2007, at 4:26 AM, Thomas Goepfer wrote:

> yes, it’s a solution (and it works !…).
> It’s the only solution ?…

Correct. poly~’s internal DSP chain is a separate entity from the
external DSP chain, and the tricks to remove feedback loops do not
transfer from the poly~ internal DSP chain to the outer DSP chain.

-Joshua

#102619

You must be logged in to reply to this topic.