How do I get an audio signal from a movie using jt.qt.movie

Aug 14, 2008 at 2:25pm

How do I get an audio signal from a movie using jt.qt.movie

How do I get an audio signal from a movie using jt.qt.movie? I’d like to send the audio signal somewhere for processing.

Thanks

Carmen

#39276
Aug 14, 2008 at 2:40pm

spigot~ is your friend

On Thu, Aug 14, 2008 at 4:25 PM, Carmen Branje wrote:
>
> How do I get an audio signal from a movie using jt.qt.movie? I’d like to send the audio signal somewhere for processing.
>
> Thanks
>
> Carmen
>

#138048
Aug 14, 2008 at 3:00pm

so I’ve got an object

jit.qt.movie @soc chair

and

spigot~ chair

but I’m still hearing the audio . .

Carmen

#138049
Aug 14, 2008 at 3:26pm

i assume you mean you’re hearing the audio coming from the qt.movie, and you don’t want that. try @vol 0.
otherwise post a patch, or explain more what the problem is.

#138050
Aug 14, 2008 at 4:43pm

here is my patch . . .

I assumed that the audio would be cut off when I put the @soc chair
in the jit.qt.movie object . . .but I still hear it when I play the video, even though, from what I gather, the audio should be sent off to spigot~ chair, which doesn’t seem to be receiving anything . .

Carmen

#138051
Aug 14, 2008 at 5:01pm

#138052
Aug 14, 2008 at 5:07pm

seems to in that it doesn’t throw an error . . . is there another way to do this?

#138053
Aug 14, 2008 at 5:58pm

I tried installing the incremental updates and I get all sorts of error.

Could this be a quicktime 7 problem?

Carmen

#138054
Aug 14, 2008 at 6:27pm

the audio is being cached correctly, am I missing a step or something somewhere?

#138055
Aug 14, 2008 at 7:18pm

okay I think I got it, but how do I stop the audio, when I stop the video the audio keeps going . . . when I restart the video its as if the video was always running and beings playing where the audio is.

Carmen

#138056

You must be logged in to reply to this topic.