Forums > MaxMSP

how to change the file path's manually?

November 22, 2008 | 8:23 pm

Hi,

I would like to get some help in the following..

I used SC to convert a Max5.patcher to a Max4 one. I worked, but needed the externals which are in the Max5 folder.
Therefore I have chosen the whole Max5 folder to be searched through in the Max4 File Preferences.

Now Max4 does not work, I can not even choose CoreAudio in DSP status,… and what makes it worse, I can not alter the File Pref. (can not erease Max5 folder, as it is not shown, and could not even add new folders to it..)

Max windows says among others…
adstatus: unable to load object bundle executable

any tips I can heal my max4?

all the best
Krisztian


November 22, 2008 | 8:40 pm

If you mean third party externals you should copy them into a folder somewhere in your Max4 search path and stop it from searching the Max5 folder. Max4 and 5 work on the same machine but it’s best to keep them separate or they will get confused.

lh


November 22, 2008 | 9:31 pm

yes, I understand this.
But now I do not really know how to undo the change as Max4 does not really behave like it has been before.

Max4 Runtime seems to remain the same. It works..

I was trying to change this file
/Applications/MaxMSP 4.6/patches/preference-editors/File Preferences.pat

but
1. it is not a text file
2. changing it with Max5. will do a Max5 patcher
3. Converting this Max5 patcher with SC into a Max4 patch does not do the job either.

any ideas?

best

ps.: Is it possible that someone just sends me this file?

best
Krisztian


November 22, 2008 | 10:06 pm

You should be able to delete files from your search path manually using the [filepath] object from any Max4 patch you create or open. Have a look at the documentation for instructions on how to query what path is saved in each search slot and how to clear it when you find the Max5 folder.

lh



grg
November 22, 2008 | 10:30 pm

Am 22.11.2008 um 22:32 schrieb tedor:
> I was trying to change this file
> /Applications/MaxMSP 4.6/patches/preference-editors/File
> Preferences.pat

thats the filepath editor patch, the paths are stores in
maxsearchpaths.txt in ~/Library/Preferences/Max 4.6 Preferences Folder.
Plain text file you can edit, deleting it and adding your personal
path again in max should work too.

g, g.


November 22, 2008 | 10:43 pm

:)

Thank you for all!

working with [filepath] could not help as Max was not functioning, but deleting the Max5 folder from maxsearchpaths.txt in ~/Library/Preferences/Max 4.6 Preferences Folder did the right thing!

great, you have saved me from reinstalling Max4.6
Respect!

All the best,
Krisztian


Viewing 6 posts - 1 through 6 (of 6 total)