how to color jit.gl.sketch based stuff multiplied by jit.gl.multiple ?

Jan 4, 2013 at 10:54pm

how to color jit.gl.sketch based stuff multiplied by jit.gl.multiple ?

hello,
I’m drawing very basic shape using jit.gl.sketch.
these latter are used with jit.gl.multiple
position, scale are okay.

I have a problem to color them using a color_matrix feeding jit.gl.multiple
I tried to specify glcolor or not in the commands passed to jit.gl.sketch … all the same.

is there an alternative to jit.gl.sketch to draw very basic lines ?
is there another way ?

any leads would be interesting for me.

#65928
Jan 7, 2013 at 10:30pm

drawing basic lines can be done with jit.gl.mesh @drawmode lines or jit.gl.path.

#237428
Jan 10, 2013 at 11:18pm

I guess my problem is a double problem.
As you mentioned, mesh drawing seems to be my way here (for other reason)
But I am still not okay with coloring stuff using jit.gl.multiple. my jit.gl.mesh instances “multiplied” by jit.gl.multiple remain grey.

#237429
Jan 10, 2013 at 11:42pm

I’m okay without jit.gl.mesh to color gridshape using the required float32 RGBA matrix feeding jit.gl.multiple.

I don’t know why I cannot color jit.gl.sketch through a color matrix feeding the gl multiple
and it is the same with jit.gl.path.
I’m missing something probably like the elephant inside the room…

#237430
Jan 11, 2013 at 1:51am

post your patch

#237431
Jan 11, 2013 at 9:31pm

here it is, Rob.

– Pasted Max Patch, click to expand. –
#237432
Jan 11, 2013 at 10:30pm

ok, the reason the gl.mesh is ignoring the color values from gl.multiple, is because you are sending it color planes from jit.gl.gridshape.

jit.gl.gridshape outputs a 12 plane matrix when matrixouput is enabled. planes 9-12 are color info, causing gl.mesh to ignore color from gl.multiple. if you don’t pass these color planes, it will work as expected.

simply insert a “jit.pack 1 @jump 8″ between the gl.gridshape and the gl.mesh. this will pass only the first 8 planes (3 position, 2 texcoord, and 3 normals).

jit.gl.sketch won’t work with gl.multiple colors, due to the way the object draws itself.

#237433
Jan 12, 2013 at 12:15am

hi,
there is a solution a bit tricky ;
remove “glcolor” message to sketch;
replace “color” to “attr.color” on multiple object
:)

– Pasted Max Patch, click to expand. –
#237434
Jan 12, 2013 at 9:12am

Thanks Rob and matmat.
Ok for the 12 plane matrix, I knew it, I got it in this case.
I didn’t know about attr.color. This sounds the way to control each object color.

THANKS a lot.

#237435
Jan 23, 2013 at 1:35pm

Hey all!
I’m having a similar issue. I tried using “attr.color” instead of color but it still won’t do the trick. Could you help me out here please?

– Pasted Max Patch, click to expand. –
#237436
Jan 23, 2013 at 2:14pm

hi
for your patch you don’t need to use “attr.color”, you can simply use “color”

– Pasted Max Patch, click to expand. –
#237437

You must be logged in to reply to this topic.