How to create a file extension?

Jun 14, 2011 at 8:35pm

How to create a file extension?

Hi, I think I’ve asked a question like this before but I’m starting to piece together how to do this, there are just a few pieces of the puzzle missing.

1) If I use Get Info in finder I can force a coll text file with a unique file extension for example .zzz to open my Max Application; however, this reveals the text file (which isn’t terrible, it just looks ugly), I could then assign that to the coll object and it would work from there. Is there any way to close this text window with code once it’s been opened this way?

2) Is there a way to commit this programmatically? Either with a shell script to assign the Open With option or do something with the standalone application to ensure only documents with the appropriate file name are opened with the standalone? Also so they no longer appear in the Open With list for all text files and Maxpats.

Was there ever a solution for ensuring that standalones didn’t become the default for opening a maxpat file?

#57614
Jun 30, 2011 at 10:02pm

Well answering my own question here because I’m feeling generous (and would like to know if this will cause a meltdown).

Duplicate and modify the info.plist Created with your app. Modify the problematic files, for example, I never want there to be an option for my app to be the default application for editing maxpats or text files.

Add the extension you’ve created an the name of the icon file you want to create. Mac’s icon composer didn’t do it for me, had to use ico2icns (think that’s what it was called).

Rebuild your app but include the info.plist you modified in the collective editor.

Add the icns to your resources. You may want to restart your finder.

#206507
Jun 30, 2011 at 10:29pm

It would be really good if this kind of information was actually in the max documentation somewhere; also how to modify menu items for stand-alones– all that kind of jumping-through-lots-of-hoops-to-get-something-simple-done sort of workflows

T

#206508

You must be logged in to reply to this topic.