Forums > Jitter

How to get FSAA with a texture

October 24, 2013 | 6:58 am

Hi everyone,

A pretty simple question which I just can’t find a solution to.

I have jit.gl.mesh connected to jit.gl.node which then go’s into a jit.gl.plane.
I then send a to_texture message to jit.gl.render and send this texture through to Syphon.

I just can’t figure out how to turn on FSAA with the texture, it works fine with jit.window.

I can’t use jit.gl.asyncread as it slows down my frame rate.

Suggestions anyone ?

All help is more than welcome !


October 24, 2013 | 10:24 am

you should use FXAA.
i created this wiki article demonstrating the technique:

http://cycling74.com/wiki/index.php?title=Anti-aliasing_with_FXAA


October 24, 2013 | 12:14 pm

Thanks a million Rob ! I’ll try it out.
Is it worth say rendering with 2 objects jit.gl.node on a dim setting of 1280 1024 and then putting the dim setting of jit.gl.render to a 1024 768 ??
I tried it out but can’t seem to get it to work. Maybe i have to try a setting with filter or interpolation on the jit.gl.texture going into syphon ??


October 25, 2013 | 6:27 am

I have two jit.gl.mesh objects going into 2 jit.gl.node, i insert 2 instances of the fxaa shader before they go into a slab chain but for the life of me I can’t Layer 2 to go over layer 1 !
They’re both transparent with the alpha as if its one layer.
I’ve tried all the combinations of blend enable and depth enable but it doesn’t help.
With all my other jit.gl.slab effects the transparency and color information is intact.
Any suggestions Rob ?


October 25, 2013 | 10:30 am

you want to apply the fxaa to the FINAL output. mix the two layers together (with gl.slab or gl.pix) then send the mixed output to fxaa.


Viewing 5 posts - 1 through 5 (of 5 total)