I can't get the Z axis working with jit.gl.multiple

Jul 12, 2011 at 7:32pm

I can't get the Z axis working with jit.gl.multiple

I’m sure I’m just making some stupid oversight, but I don’t seem to be able to control the depth of instances of a jit.gl.multiple. x and Y axes work fine. What have I forgotten to set properly? Stripped-down example is below.

Thanks,

M

– Pasted Max Patch, click to expand. –
#57993
Jul 13, 2011 at 11:25pm

i been in a similar situation in the past and setting targetmode of gl.multiple to 1 solve it… but the true is that even the explanation in the help file about targetmode attr. i didnt understand why z axis have this behavior and no the others…

#208165
Jul 14, 2011 at 8:43pm

that does work, but one thing about draw_raw is that you then lose your lighting_enable and so on. And the scale is completely different, and so forth…

thanks for the suggestion, though!

M

#208166
Jul 14, 2011 at 10:50pm

yes, with the targetmode=1 the ob3d attributes from the target object are ignore, but if you want lighting you can enable it in the gl.multiple object… and the same for scaling, but maybe you dealing with a big patch and this is a big change.. dont know… is up to your patch… :)

#208167
Jul 15, 2011 at 2:26pm

Oh. Duhh. thanks for reminding me….

#208168

You must be logged in to reply to this topic.