Forums > Max For Live

Ignore click but still be mappable ?

April 27, 2014 | 8:54 am

If i select "ignore click" for a parameter, i am no longer able to map it to MIDI or Keystrokes. Am i missing something ?


April 27, 2014 | 10:53 am

Does this resolve your concerns?

– Pasted Max Patch, click to expand. –

April 27, 2014 | 11:08 am

Sorry, i should have been more specific. I’m talking about a m4l device, and the way i can map GUI elements (buttons in this case) with live’s mapping system. Whenever you select ‘ignore click’ i can’t map it in live.


April 27, 2014 | 11:40 am

You mean you want a live.button that is visible and mappable but not clickable?


April 27, 2014 | 3:29 pm

Exactly !
The reason is : live.button is a bit weird when mapped to a midi note. The only way to have it outputting a bang on note on only is to set it to output a bang on transition to both zero>one and one>zero. But then, when you click it with the mouse, it sends 2 bangs.
That’s really annoying, since i have to always put 2 buttons : 1 regular button for mouse action and 1 live.button for live mapping.


April 28, 2014 | 7:22 am

Yes, that is annoying, and I’ve never understood why live.button can’t also be mappable when it’s not in ‘both’ mode. Maybe you should submit a feature request? For now, though, the only thing I can think of other than your solution is to filter out bangs that come too soon after the previous bang, but admittedly that’s not an ideal fix.


April 28, 2014 | 8:45 am

Ok ! Maybe it’s feature request time (i seem to be not alone to be bothered by live.button).
Filtering bangs is a good idea, thank you !


April 28, 2014 | 12:12 pm

feature request for sure :)

but for a fix, if you know there’s always nothing but 2 bangs coming from live.button at a time, instead of trying to filter by timing, ‘zl group’ is nice too:

– Pasted Max Patch, click to expand. –

August 28, 2014 | 1:25 am

Hi Raja, how does the zl 2 group 2 work ? The first 2 is the length of the list ? Do you have to give it as an argument ?
There’s something else I don’t get and never noticed : live.button is set to bang on both transitions type but it doesn’t when you uncheck the toggle. But if you connect a print to the live.button, you see that two bangs are sent when you set the toggle to 1…

+ 1 for bug / feature fix, call it the way you want…


August 31, 2014 | 4:59 pm

hey SM, hope I am getting at what you’re after.. the zl.group object puts out lists of the size you determine as argument after it has received as many items (iterated or in lists). This will not work with bangs though, hence all you need to do is send your live.button’s bangs to a toggle object (1/0) and either place a ‘sel 1′ object after it to filter out the zeros or a ‘zl group 2′ object – the latter would require a ‘loadmess x’ so a zero>one transition of the live.button will output from zl group and not the other way around, another bang afterwards would then be required too for neutral processing. the ‘select 1′ options is maximum good though: live.button > toggle > sel 1 > bang (when receiving message 1).


Viewing 10 posts - 1 through 10 (of 10 total)