intel performance / jit.rota

Mar 23, 2007 at 10:37am

intel performance / jit.rota

hello out there!

since years i use a very simple patch including jit.rota for moving arround the video source. in the moment i use it on my powerbook g4, 1,5 ghz… and it works very well (640×480, 25fps constant).

today i tried it out on a intel machine for the first time, and i was shocked. (imac intel core duo 2,16ghz, 1gb ram, 10.4.9 osx, max 4.6.2, jitter 1.6.2, quicktime 7.1.5): even with a resolution of 320×240 the framerate gets down to 15-16 fps!!! (my old ibook g3 worked better…)

does anyone know the reason for that, and what can i do? i would like to buy a macbook pro…

thanks!

#30984
Mar 23, 2007 at 1:20pm

you might be opening this in rosetta, or running your max msp as a
ppc app, not as an x86 app?
send the patch.

I had HUGE performance gains moving to intel.

On Mar 23, 2007, at 11:37 AM, expjektor wrote:

>
> hello out there!
>
> since years i use a very simple patch including jit.rota for
> moving arround the video source. in the moment i use it on my
> powerbook g4, 1,5 ghz… and it works very well (640×480, 25fps
> constant).
>
> today i tried it out on a intel machine for the first time, and i
> was shocked. (imac intel core duo 2,16ghz, 1gb ram, 10.4.9 osx, max
> 4.6.2, jitter 1.6.2, quicktime 7.1.5): even with a resolution of
> 320×240 the framerate gets down to 15-16 fps!!! (my old ibook g3
> worked better…)
>
> does anyone know the reason for that, and what can i do? i would
> like to buy a macbook pro…
>
> thanks!

v a d e //

http://www.vade.info
abstrakt.vade.info

#99812
Mar 23, 2007 at 1:29pm

Quote: vade wrote on Fri, 23 March 2007 14:20
—————————————————-
> you might be opening this in rosetta, or running your max msp as a
> ppc app, not as an x86 app?
> send the patch.
>
> I had HUGE performance gains moving to intel.
>

Same here. Send the patch and I’ll compare.

Mattijs

#99813

You must be logged in to reply to this topic.