Forums > Jitter

Intercom, multi video-stream over network

November 10, 2011 | 4:21 pm

Hi there!

I have made a video-stream connection between 2 Mac’s over a network, wich works perfect. There is also an audio-stream in it and a pulse to call. When I expand the patch true more Mac’s, it won’t work anymore.

Setup: (you need 2 Mac’s)
Mac1_ip2.0.0.31 Basic server to Call an other Mac, includes a webcam and microphone
Mac2_ip2.0.0.41 Mac at company1, includes a viewer, a microphone, buttons to answer a call and ending it.
Mac3_ip2.0.0.42 Mac at company2, "

Choose a Network with ip2.0.0.31 for Mac1
Open: Mac1_1xAV_2.0.0.31_to company_1

Choose a Network with ip2.0.0.41 for Mac2
open: Mac2_Deurbel_company_1_2.0.0.41

Press the Start button in both patches. The webcam (iSight macbook) opens and the ports opens to receive the video and audio streams.

This will problably work right and also patches: Mac1_1xAV_2.0.0.31 to company_2 & Mac3_Deurbel_company_2_2.0.0.42

When I combine these in Mac1_multi_AV_2.0.0.31 it won’t work anymore… what is wrong? Please help me out!

Thanks a lot!

Paul


November 29, 2011 | 4:15 pm

Hi,

I’m trying these patches but they’re not working. What do you exactly mean by "Choose a Network with ip…. for Mac…"?

carl


November 29, 2011 | 11:30 pm

Hi again,

I have your patches working, but once I use jit.windows instead of jit.pwindows the frame rate goes down (really down) and whereas with the latter I would get clean videos, with the former I get them all broke into pieces (of time). Do you know how to solve this?

Thanks,

Carl


Viewing 3 posts - 1 through 3 (of 3 total)