Forums > MaxMSP

Issue with addition


Joe
July 3, 2013 | 3:59 pm

Hi guys,

I have a patch here which adds together two numbers simple as.. it works fine

I then wanted to change the number being added to a decimal… doesnt work

Any ideas?

<code>

– Pasted Max Patch, click to expand. –

</code>


July 3, 2013 | 4:31 pm

Unless you specify otherwise, Max expects to be working with integers [Yeah, I know. It's been this way forever, though]. Take a look at the "Number boxes" section here:

http://www.cycling74.com/docs/max6/dynamic/c74_docs.html#basicchapter03



Joe
July 4, 2013 | 7:07 am

Okay I took a look at number boxes and simple math but i am still not getting the results I need.

I have a patch with 5 different methods, non of which add 0.25 to the total number..

<code>

– Pasted Max Patch, click to expand. –

</code>



dtr
July 4, 2013 | 8:22 am

This is basic Max behavior and shared by tons of objects.

<code>

– Pasted Max Patch, click to expand. –

</code>

Btw, you’ve been opening new topics/help requests every day in the last couple of weeks and a lot of them for basic issues. Makes me wonder if you’re checking the standard resources before posting them: object’s help patches and references, the included max/msp/jitter tutorials, searching this forum, etc.



Joe
July 4, 2013 | 10:18 am

Thanks for that input…

I got it working in the end with the use of an accum 0.1

<code>

– Pasted Max Patch, click to expand. –

</code>


July 5, 2013 | 3:08 pm

Thank you this code is doing work


Viewing 6 posts - 1 through 6 (of 6 total)