jagged edges on rotated videoplane

May 7, 2012 at 1:45pm

jagged edges on rotated videoplane

Hello. This has been bugging me for a while now… when a videoplane is rotated the edges are aliased, looking quite jagged. Is there a way to antialias these edges to get a smoother looking result? I’ve poked around the forums and documentation and found nothing to this effect.

Thanks.

#63452
May 7, 2012 at 2:06pm

I haven’t encountered this but perhaps raising the ‘dim x y’ of the videoplane can get rid of it?

#228785
May 7, 2012 at 9:12pm

I’m not in a position to test this, nor have I tried it before, but I do recall there being an option called interp on the videoplane and many other objects. Interpolation I believe has something to do with aliasing/antialiasing so perhaps that is worth a try.

#228786
May 8, 2012 at 4:22am

add the attribute @fsaa 1 to your jit.window.

#228787
May 8, 2012 at 11:52am

Thank you so much! Full screen anti-aliasing indeed! That does the trick. And just in time for our video installation at the Mapping Festival. I’ve been wanting to get more accurate focus on a lot of little screens but needed to do a small bit of rotation which, before fsaa, resulted in big jagged edges.

http://mappingfestival.ch/2012/

#228788
May 8, 2012 at 12:32pm

ah that kind of jagged edges :)

#228789

You must be logged in to reply to this topic.