Forums > MaxMSP

Japanese Unicode text

August 16, 2009 | 12:14 am

I have a coll object referencing a UTF-8 formatted text file with entries that contain Japanese text such as:

1, symbol "それ"
2, symbol "そちら"
etc…

If I tried to output these for example to a message object, I would get
"square square" (as in an actual squares)
"square square square"

It’s as though Max cannot interpret the Japanese Unicode characters, though as I understand it, Max is suppose to be able to handle Unicode. If it can’t be done with a coll referenced Unicode text file, I am open to other objects including those of Jitter.

I have searched the forums and Google, but to no avail.

The strange thing is that I can double click on the coll object and the opened text file will display the Japanese characters, but it’s at the point when I output the text that it becomes squares. Maybe it has something to do with outputting the text and a "symbol"?

I can also type the Japanese characters directly into a message object and they will display fine, so my guess is it might have something to do with the "coll" object.

Any help would be greatly appreciated as I have been trying to work this out on and off for a few years (believe it or not) with Max 4 and 5 OS X :S



Eli
August 16, 2009 | 12:22 am

Check out the "Unicode_Tips_for_Japanese" patch under the "Latest" tab in the Examples overview (Menubar->Extras->ExampleOverview), and see if changing the Default/Fallback/System Font preferences helps.

Eli


August 16, 2009 | 4:17 am

どうもありがとう

Thanks a lot, this was very helpful!

I ended up changing the formatting of my coll file from

1, symbol "これ";

to

1, これ;

and had that feed into a message box with

clear, font Osaka 12, moveto 10 30, write $1

which fed into an "lcd" object.

Again, much appreciated.


Viewing 3 posts - 1 through 3 (of 3 total)