Japanese Unicode text

Aug 16, 2009 at 12:14am

Japanese Unicode text

I have a coll object referencing a UTF-8 formatted text file with entries that contain Japanese text such as:

1, symbol “γγ‚Œ”
2, symbol “そけら”
etc…

If I tried to output these for example to a message object, I would get
“square square” (as in an actual squares)
“square square square”

It’s as though Max cannot interpret the Japanese Unicode characters, though as I understand it, Max is suppose to be able to handle Unicode. If it can’t be done with a coll referenced Unicode text file, I am open to other objects including those of Jitter.

I have searched the forums and Google, but to no avail.

The strange thing is that I can double click on the coll object and the opened text file will display the Japanese characters, but it’s at the point when I output the text that it becomes squares. Maybe it has something to do with outputting the text and a “symbol”?

I can also type the Japanese characters directly into a message object and they will display fine, so my guess is it might have something to do with the “coll” object.

Any help would be greatly appreciated as I have been trying to work this out on and off for a few years (believe it or not) with Max 4 and 5 OS X :S

#45118
Aug 16, 2009 at 12:22am

Check out the “Unicode_Tips_for_Japanese” patch under the “Latest” tab in the Examples overview (Menubar->Extras->ExampleOverview), and see if changing the Default/Fallback/System Font preferences helps.

Eli

#162601
Aug 16, 2009 at 4:17am

γ©γ†γ‚‚γ‚γ‚ŠγŒγ¨γ†

Thanks a lot, this was very helpful!

I ended up changing the formatting of my coll file from

1, symbol “γ“γ‚Œ”;

to

1, γ“γ‚Œ;

and had that feed into a message box with

clear, font Osaka 12, moveto 10 30, write $1

which fed into an “lcd” object.

Again, much appreciated.

#162602

You must be logged in to reply to this topic.