Forums > Javascript

Javascript Reference with MAX5


sxa
April 30, 2008 | 9:06 am

I notice there’s no new version of the MAX4.6 JavascriptInMax.pdf reference detailing classes etc installed with MAX5. Are there any significant changes or other updates to the Javascript engine and/or classes, or is it okay to rely on the old MAX4.6 documentation?


April 30, 2008 | 4:14 pm

On 30 avr. 08, at 11:06, sean ahern wrote:

> I notice there’s no new version of the MAX4.6 JavascriptInMax.pdf
> reference detailing classes etc installed with MAX5. Are there any
> significant changes or other updates to the Javascript engine and/or
> classes, or is it okay to rely on the old MAX4.6 documentation?

You can still rely on the one in 4.6. Although it will reappear in the
next incremental.

ej


April 30, 2008 | 4:18 pm

On Apr 30, 2008, at 2:06 AM, sean ahern wrote:
>
> I notice there’s no new version of the MAX4.6 JavascriptInMax.pdf
> reference detailing classes etc installed with MAX5. Are there any
> significant changes or other updates to the Javascript engine and/or
> classes, or is it okay to rely on the old MAX4.6 documentation?

The biggest fundamental change is that the JS engine now uses JS 1.6.
There have been some minor changes to the way JS calls work with
patcher scripting, and we’ll be updating the JS documentation over the
coming months. In the next incremental, the JS documentation will be
present in the integrated online documentation but won’t have all of
the minor changes immediately. For most users there will be no
difference in behavior in the JS API, and the Max 4.6 JS documentation
can still be used.

Thanks,
Joshua


May 22, 2008 | 9:47 pm

Quote: jkc wrote on Wed, 30 April 2008 10:18
—————————————————-
> The biggest fundamental change is that the JS engine now uses JS 1.6.

Just FYI, if no one else has mentioned it yet, is that the Max5 docs, Javascript Tutorial Chapter 1, lists Max as still having a 1.5 interpreter. I figure maybe it’s old and out of date, but this thread is the first I’ve heard that Max5 uses 1.6


January 31, 2010 | 4:29 pm

i noticed that this morning as well. i thought i was seeing things.


Viewing 5 posts - 1 through 5 (of 5 total)