JBridgeM

Apr 17, 2012 at 2:17am

JBridgeM

Has anyone played with this with Max? Is it reliable?
(Yeah, I know it’s only 10 Euro but I don’t want to risk installing it if it will screw things up that I need for audio work outside of Max.

http://jstuff.wordpress.com/jbridgem/

#63027
Apr 17, 2012 at 4:14am

It does not look like anything capable of breaking your system. VST hosting, unlike rewire et al, is taken care of by the individual DAW. This is why all the NI stuff ships as both executable and vst dll. Unless your DAWs (max included) share a vst plugin folder, sadness should not occur.

#227461
Apr 17, 2012 at 12:19pm

All my DAWs share the vst plugin folder, using the standard folder.

#227462
Apr 17, 2012 at 3:41pm

Then it would break down by individual daw, based on vst loading. Each daw will have a separate whitelist/blacklist of vsts. Once a particular vst fails to load/breaks the daw it will refuse to load it until you force it to by either manually overriding in daw configuration or removing it from the vst folder, running the daw, and replacing it to make the daw auto-redetect it.

NOTE: I believe the identical functionality is availsble (for “free”) in REAPER. Yay reaper!

#227463
Apr 17, 2012 at 3:47pm

That is to say, this thing in and of itself would get blacklisted – not the 32-bit vst. Most 32-bit vsts I have encountered run on 64-bit (waves is a sad exception, but they ain’t nuthin compared to voxengo anyway) without assistance, just in 32-bit “compatibility mode” (IE no performance boost from 64-bit system)

#227464
Apr 17, 2012 at 3:50pm

My concern was whether the original VSTs would still be accessible in the case that this bridge is NOT reliable.

#227465
Apr 17, 2012 at 7:09pm

Sure they should be. In fact they should be loaded along with the bridge. If you use the bridge, then you will select the plugin you want to bridge. If you use the unbridged plugin it will run in 32bit mode no problem. You should even be able to run 2 instances of the plugin, briged and unbridged.

#227466

You must be logged in to reply to this topic.