Forums > MaxMSP

jit.anim.node & subpatchers; also blend_enable bug

December 30, 2011 | 5:14 am

It seems that jit.anim.node can’t communicate through patch cords connected to inlets and outlets – that is, for example, an anim.node in the main patch can’t parent an anim.node in a subpatch. I assume there’s a reason for this, but on the other hand it means you can’t encapsulate with impunity. It would be much more convenient if it were possible.

On another topic, currently, once I set blend_enable 1 on any gl object, blend_enable 0 no longer has any effect – the only way to turn blending off is to reconstitute the object.

OS X 10.7.2, PBP, 6.0.2


December 30, 2011 | 4:20 pm

the patchcord features of anim.node only work with direct connections between objects.
this is the same for other objects that use patchcord connections, such as pattr, attrui, gl.material, etc.

fortunately, you can simply set the @anim attribute to the name of an anim.node object.
i will sometimes do this:

– Pasted Max Patch, click to expand. –

December 30, 2011 | 4:35 pm

i can’t reproduce the blend_enable bug.
do you have a patch?

– Pasted Max Patch, click to expand. –

December 30, 2011 | 5:52 pm

Hi Robert -

Excellent tip on @anim attribute. Solves everything.

Re blend_enable: Figured it out. Inadvertently had @blend_enable 1 on my jit.gl.camera, which then apparently sets blending for everything in its context. Took it out and all is well.

Thanks again.


December 30, 2011 | 7:28 pm

setting gl attribute like blending, color, mat_*, poly_mode, etc. on a camera will override the settings for the attributes of gl objects drawn. This allows for different views with different looks. For example, if you want one camera to show a wireframe view, set the poly_mode 1 1 on the camera. It doesn’t actually modify the attribute values for the individual objects though. It just overrides them.


Viewing 5 posts - 1 through 5 (of 5 total)